Elantra sputtering on acceleration and rough idle. - Hyundai Forum: Hyundai Performance Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 02-28-2004, 10:37 PM Thread Starter
Junior Member
 
Join Date: Feb 2004
Location: , Non-US
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Elantra sputtering on acceleration and rough idle.

So I hit the gas and the engine attempts to rev up, but ends up sputtering along till it catches again and whirls up. It happens in all gears when going past a certain point on the gas pedal. Thought it might be dirty spark plugs, so I changed them out. Problem fixed...For 300kms. Now its back. Could it be my ignition coil? Maybe something else, like TPS. Any Ideas...Thanks

ps. Check engine light had come on until I changed the Plugs, its gone now, but I expect it to be back shortly.
99elantragreen is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 02-28-2004, 11:47 PM
Senior Member
 
hyundaiexcelracer's Avatar
 
Join Date: Mar 2003
Location: Uxbridge, MA
Posts: 863
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to hyundaiexcelracer
Re: Elantra sputtering on acceleration and rough idle.

it sounds like what happened to my car, check the fuel injectors plugs ( wires that plug into the fuel injector) my car wouldn't catch in the gear then buck when it caught, then it would rev up really high while idling, and then almost stall, and rev high and stall, it was all because one of the plugs wasn't plugged in, just check them, hopefully that fixes the problem

The faster you drive through a red light, the less chance you have of getting hit.
hyundaiexcelracer is offline  
post #3 of 9 Old 02-29-2004, 12:02 AM Thread Starter
Junior Member
 
Join Date: Feb 2004
Location: , Non-US
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Re: Elantra sputtering on acceleration and rough idle.

Cool, will check. Anyone else got any thoughts??
99elantragreen is offline  
 
post #4 of 9 Old 02-29-2004, 01:41 AM
Senior Member
 
shadowcat357's Avatar
 
Join Date: Jan 2003
Location: Halifax, Non-US
Posts: 436
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Elantra sputtering on acceleration and rough idle.

I am having similar problems. Check you electrical system distributor, wires, coil pack, and alos have a look at your timing. Maby fuel injectors are dirty. Or look at checking your fuel pump?

When I have fun I like to make things squeal,wether its my tires or my girlfreind

2001 Tibby mods
AOS CAI, Front Strut Bar, Clear Corner, B&M Short Throw Shifter
shadowcat357 is offline  
post #5 of 9 Old 03-03-2004, 05:45 PM
Junior Member
 
teezer's Avatar
 
Join Date: Feb 2004
Location: , Non-US
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Elantra sputtering on acceleration and rough idle.

yup check the fuel pump, I'm having a problem with mine at the moment- I'm unable to accelerate over 2500 rpm or it'll start to sputter, as it is not getting eneugh gas. the pump is making strange kind of a noise also. and in your case it also might be the filter before the pump (between the tank &the pump there should be one- Im not an expert)
teezer is offline  
post #6 of 9 Old 03-04-2004, 02:02 AM
Senior Member
 
faithofadragon's Avatar
 
Join Date: Aug 2002
Location: , NM
Posts: 2,164
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to faithofadragon
Re: Elantra sputtering on acceleration and rough idle.

get it scanned

it could also be a bad maf they tend to act kind of crazy when they go out

typing this just cuz mouse lied to me and said we can put pics back in here

stupid mouse
faithofadragon is offline  
post #7 of 9 Old 03-04-2004, 01:37 PM
Member
 
Join Date: Oct 2003
Location: Orillia, Non-US
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Re: Elantra sputtering on acceleration and rough idle.

i sounds like dirty injectors . run some injector cleaner through it. see if that helps.
elantrase is offline  
post #8 of 9 Old 03-04-2004, 02:39 PM
Senior Member
 
Acid7711's Avatar
 
Join Date: Nov 2002
Location: , IL
Posts: 745
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Acid7711
Re: Elantra sputtering on acceleration and rough idle.

I had the EXACT same problem when I first got my car, new plugs, new wires, problem solved.

Owner and Webmaster of:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

[image]
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
href="
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
target="_blank">
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
google_ad_section_end -->
Acid7711 is offline  
post #9 of 9 Old 03-04-2004, 10:06 PM
Senior Member
 
elantrax's Avatar
 
Join Date: May 2003
Location: Atlantic City, NJ
Posts: 898
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to elantrax
Re: Elantra sputtering on acceleration and rough idle.

check make sure your actual plugs aint getting coated with oil etc... and stuttering another idea to try.

Focus Hunter
elantrax is offline  
Sponsored Links
Advertisement
 
Reply

  Hyundai Forum: Hyundai Performance Forum > Model Specific Forums > Elantra


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome