My speedometer doesnt work anymore, why? - Hyundai Forum: Hyundai Performance Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 Old 01-21-2003, 02:43 PM
Senior Member
 
Ice Vulcan's Avatar
 
Join Date: Dec 2002
Location: , Non-US
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Default My speedometer doesnt work anymore, why?

My speedometer doesnt work anymore, everything else yes ! why??? it's minus 30 C now outside !!

How much could cost to fix it ???

thanks !
Ice Vulcan is offline  
Sponsored Links
Advertisement
 
#2 Old 01-21-2003, 04:16 PM
Senior Member
 
stickshift's Avatar
 
Join Date: Feb 2002
Location: Ottawa, Non-US
Posts: 6,806
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to stickshift
Default Re: My speedometer doesnt work anymore, why?

The speedometer is run by a cable... if you were to pull the gauge cluster out, you'd see the end of it sticking out of its little bracket (all this is assuming your Scoupe is similar to my 97 Accent).
The cable could be broken, or the mechanism in the transmission that turns the cable could be broken.
Something similar happened to my dad's old Civic years ago... I believe the cable had snapped.


Automotive journalism ninja
stickshift is offline  
#3 Old 02-03-2003, 08:39 PM
Senior Member
 
Nackers's Avatar
 
Join Date: Jan 2002
Location: shirland, IL
Posts: 102
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Nackers
Default Re: My speedometer doesnt work anymore, why?

Hey, my 01 accent is sticking too but I say the hell with it. You dont really need to know how fast your going. :hmmm:

www.cardomain.com/id/nackersaccent ~My accent and my G/F Eclipse
www.cardomain.com/id/nackers ~The Eclipse (with CF hood)
Nackers is offline  
#4 Old 02-05-2003, 07:06 AM
Senior Member
 
perlplay's Avatar
 
Join Date: Sep 2002
Location: Cinebar, WA
Posts: 2,412
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default Re: My speedometer doesnt work anymore, why?

Your 01 Accent? dude...that's under warranty...get it fixed before you get any problems from it. JMOT. aranoid::hmmm:

Visit <a href="http://hyundai.perlplay.com/" border=0 target="newWindow">Hyundai.PerlPlay.com</a> for more info, photos, links, etc.<br><br>If it's high and there's water below, I'll jump it.
perlplay is offline  
#5 Old 02-05-2003, 11:01 AM
Senior Member
 
skierd's Avatar
 
Join Date: Jun 2001
Location: Glen Burnie, MD
Posts: 6,344
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to skierd
Default Re: My speedometer doesnt work anymore, why?

Ice- its prolly frozen solid and broke when you tried to drive.

accentstrracer-GET TO THE DAMN DEALERSHIT. You have a warranty for a reason, use it!

Never run out of real estate, traction & ideas at the same time.

2008 yamaha WR250R - no car, no worries
1998 Accent L - #13 FSP SCCA Solo2 in 2005, SOLD
2001 Accent GS - RIP
skierd is offline  
#6 Old 02-06-2003, 02:39 AM
Senior Member
 
Jed118's Avatar
 
Join Date: Apr 2002
Location: Mississauga, Ontario
Posts: 9,190
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Jed118
Default Re: My speedometer doesnt work anymore, why?

Scoupes and Excels had a cable stretch prblem, otherwise the ferrite core got stuck with a plastic gear off the speedo. Very common problem. Scrap yard and $20 later you got it fixed

1987 Hyundai Stellar CXL 4G63

-Front Fog lamps
-6K HID Kit
-1988 Firebird spoiler
-Monte Carlo SS tip
-Ford EXP 15x6 alloys all around
-Sony Xplod deck

My other cars are Hyundai Ponys! 1987 (4G16 "Saturn" 4spd), 1986 (4G14 5spd), 1984 (4G63 5spd)
Jed118 is offline  
#7 Old 02-06-2003, 08:23 PM
Senior Member
 
cclngthr's Avatar
 
Join Date: Dec 2002
Location: Tacoma, WA
Posts: 3,497
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to cclngthr
Default Re: My speedometer doesnt work anymore, why?

Quote:
Originally posted by skierd
[body]
Ice- its prolly frozen solid and broke when you tried to drive.

accentstrracer-GET TO THE DAMN DEALERSHIT. You have a warranty for a reason, use it!
[/body]
I agree.

When I got my Accent, I had the dealer remove the cable, put a little lithium grease on it, and I have had no problems. The grease is water resistant and can lube at low temps as well as high temps. If water does get in there, the grease protects the cable enough to keep it from seizing.

http://www.hyundaiperformance.com/forums/image.php?
cclngthr is offline  
Sponsored Links
Advertisement
 
Reply

  Hyundai Forum: Hyundai Performance Forum > General Forums > Maintenance and Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome