oil light? - Hyundai Forum: Hyundai Performance Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 Old 10-09-2007, 12:38 AM
Senior Member
 
Veritas's Avatar
 
Join Date: May 2007
Location: Pittsburgh
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Veritas
(Thread Starter)
Default oil light?

I just took my car for a 5 hour trip, there and back, for a rugby game in Quantico. On my way home I noticed my oil light would flicker...and then go away. It never stays on though.

Today I noticed it still does it, usually in lower girls or when the rpm drops. I tried checking the oil, and it was hard to tell how much I had because it looks like the dip stick was burned...so it was hard to tell. I just changed oil when I got the car at the beginning of the summer. Any ideas?

2000 1.5 lc
DIY clear corners / black euro tails
ebay tib short shifter
15" Konig Divas
warm air intake
evofusion cat back
msd wires
Veritas is offline  
Sponsored Links
Advertisement
 
#2 Old 10-09-2007, 01:17 AM
Senior Member
 
Jsharptooth91's Avatar
 
Join Date: Nov 2002
Location: Southern, WA
Posts: 1,165
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to Jsharptooth91
Default

Either your low on oil or your sensor is at fault.

More pix of beta swap Here

Beta swap DIY @ Hyundaiaftermarket.org

Car domain is Here

Cheers
Jsharptooth91 is offline  
#3 Old 10-09-2007, 01:28 AM
Senior Member
 
Veritas's Avatar
 
Join Date: May 2007
Location: Pittsburgh
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Veritas
(Thread Starter)
Default

yahh...thats the only thing i could come up with.

im going to see if i can clean the dip stick a lil better tmrw and see where that gets me.

2000 1.5 lc
DIY clear corners / black euro tails
ebay tib short shifter
15" Konig Divas
warm air intake
evofusion cat back
msd wires
Veritas is offline  
#4 Old 10-09-2007, 01:45 AM
Senior Member
 
ereeves116's Avatar
 
Join Date: Jan 2007
Location: Saint Paul, MN
Posts: 1,080
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

i had the same problem. it flickered a lot more when i went around turns also. and it turned out to be low oil that managed to barely trip the sensor. the problem was that my oil cap on the top of the motor is leaking, check yours?

i think i need to get a new o-ring for it because i've no leaks below.

Admin needs to stop deleting my sigs.
ereeves116 is offline  
#5 Old 10-09-2007, 01:52 AM
Senior Member
 
Veritas's Avatar
 
Join Date: May 2007
Location: Pittsburgh
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Veritas
(Thread Starter)
Default

hey, good call. ill check that. thx

2000 1.5 lc
DIY clear corners / black euro tails
ebay tib short shifter
15" Konig Divas
warm air intake
evofusion cat back
msd wires
Veritas is offline  
#6 Old 10-09-2007, 03:44 AM
Senior Member
 
Asian_907's Avatar
 
Join Date: Feb 2005
Location: Anchorage, AK
Posts: 687
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Asian_907
Default

Well...

When you check your oil, make sure your engine is cold...

Howie~
Asian_907 is offline  
#7 Old 10-09-2007, 03:45 AM
Senior Member
 
^scythe^'s Avatar
 
Join Date: Oct 2006
Location: Australia
Posts: 596
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to ^scythe^
Default

My dip stick is fairly burnt as well...
But i can still tell what the level is...

If your light is comming on then i would say that you dont have enough oil to coat the dipstick...
When its almost time for a service my oil level is fairly low...
Down around the twisted bit at the bottom of the dip stick...
My light hasn't come on yet tho...
And my light works...




Cheers
scythe

My car:
2000 Accent LC 3 door...
SS inductions CAI...
Exedy HD stage 1 clutch...
^scythe^ is offline  
#8 Old 10-09-2007, 07:17 AM
Senior Member
 
Join Date: Oct 2005
Location: , IA
Posts: 168
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default

Are you using a Hyundai oil filter? I have seen where the oil filter causes the light to come on. Especially Fram filters.
imcastock is offline  
Sponsored Links
Advertisement
 
Reply

  Hyundai Forum: Hyundai Performance Forum > General Forums > Maintenance and Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome