2012 Hyundai Veloster SR Turbo - Startingand RPM dial issues - Hyundai Forum: Hyundai Performance Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-14-2019, 02:15 AM Thread Starter
Junior Member
 
Join Date: Mar 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2012 Hyundai Veloster SR Turbo - Startingand RPM dial issues

Hi all, I am a new user wanting to see if anyone is able to shed some light on what could be causing the issues with my Veloster before I book it in to be assessed by the dealership.

Over the past couple of days when I go to start the car in the mornings and afternoons, it attempts to turn over for a 3-4 seconds before fully starts. Yesterday morning when it did eventually start it idled very strangely and sounded like it was going to stall. I turned the car off, then started it again and it was fine. On one occasion in the middle of the day, the car kept trying to turn over but did not start at all. I left it for an hour or so and then it started fine.

Yesterday afternoon after pushing the start button, it took a few seconds once again before it fully fired up however this time the RPM dial was not working. The car also felt very laggy and sounded like it was idling very low.

There are no lights on the dash to indicate any issues. I have had coils replaced in the past however the car went into limp mode and a engine light appeared.

I will be getting my battery check this afternoon to see if that is the cause of these issues however I'm not convinced due to the sickly idling sound and RPM dial.

Thanks
ClavaB is offline  
Sponsored Links
Advertisement
 
Reply

  Hyundai Forum: Hyundai Performance Forum > General Forums > Maintenance and Help


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome