Gas Smell - Hyundai Forum: Hyundai Performance Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 Old 01-15-2007, 07:37 PM Thread Starter
 
Join Date: May 2006
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Gas Smell

I have been driving my car for about 6 months now and on random occasions I get a gas smell when I fill the tank all the way. I have put the car on a lift at work and give it the old lookseedoodle. I looked at the tank, lines, and the injectors and I saw no leaks. The smell never last that long though. Usually once I get the guage needle to go down a bit it goes away. Anyone have a bit of knowledge of that?
bboyitim is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 01-15-2007, 07:46 PM
Senior Member
 
WytchDctr's Avatar
 
Join Date: Aug 2001
Location: ...., TX
Posts: 7,118
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to WytchDctr
did you check the top of the pump/filter assembly under the rear seat? Make sure the bolts are tight etc?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
WytchDctr is offline  
post #3 of 13 Old 01-15-2007, 08:06 PM Thread Starter
 
Join Date: May 2006
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by WytchDctr
did you check the top of the pump/filter assembly under the rear seat? Make sure the bolts are tight etc?
I didn't really look at that I was mainly looking for leaks. Is it under the passenger side or driver side rear?
bboyitim is offline  
 
post #4 of 13 Old 01-15-2007, 08:18 PM
Senior Member
 
WytchDctr's Avatar
 
Join Date: Aug 2001
Location: ...., TX
Posts: 7,118
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to WytchDctr
mines right in the middle, not sure if its diffrent on a tib.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
WytchDctr is offline  
post #5 of 13 Old 01-16-2007, 01:56 PM Thread Starter
 
Join Date: May 2006
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by WytchDctr
mines right in the middle, not sure if its diffrent on a tib.
I have a 97 base model. It's a 1.8L. If that's what you have. I think my fuel filter is under the hod thugh.
bboyitim is offline  
post #6 of 13 Old 01-23-2007, 06:04 AM
 
Join Date: Jan 2007
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
He means under the rear bench where the fuel pump is located.

Have you also checked the charcaol canister lines. How does the car run
Meredith is offline  
post #7 of 13 Old 01-23-2007, 01:36 PM Thread Starter
 
Join Date: May 2006
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Meredith
He means under the rear bench where the fuel pump is located.

Have you also checked the charcaol canister lines. How does the car run
So can I lift the rear bench without damaging it? The car runs ok. The Idle gets rough when I turn on electrical things. I flushed and Seafoam'd the motor which made it lighten up on all that stuff. =)
bboyitim is offline  
post #8 of 13 Old 02-01-2007, 07:45 PM
 
Join Date: May 2003
Posts: 897
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I got the same exact problem on my 00 Elantra and cant figure it out! I got a fuel smell at certain times and other times I dont. I checked my lines on the lift, replaced fuel filter, checked canister, put new fuel cap, checked injectors and im still tryingto find out whats wrong. I plan to check it over again this sat and see whats up. If you find whats wrong with yours make sure to give me a holla on here and whatnot.
elantrax is offline  
post #9 of 13 Old 02-03-2007, 04:48 PM
 
Join Date: May 2003
Posts: 897
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Problem fixed!

Went into my old job today and put the car on the lift and around the back where the evap canister is you have a hose running into it well after clamping it down, we put the car on a smoke machine which basically pumps smoke nitrogen into the gas and shows any leaks. After pumping the smoke we could see gas flowing out the top of the fuel filter! Replaced the top fuel filter inlet o-ring and now no more gas leaking under pressure.
elantrax is offline  
post #10 of 13 Old 03-03-2007, 11:09 PM Thread Starter
 
Join Date: May 2006
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by elantrax
Problem fixed!

Went into my old job today and put the car on the lift and around the back where the evap canister is you have a hose running into it well after clamping it down, we put the car on a smoke machine which basically pumps smoke nitrogen into the gas and shows any leaks. After pumping the smoke we could see gas flowing out the top of the fuel filter! Replaced the top fuel filter inlet o-ring and now no more gas leaking under pressure.
Thanks dude. Once my car is back on the road I will do that. =)
bboyitim is offline  
Sponsored Links
Advertisement
 
Reply

  Hyundai Forum: Hyundai Performance Forum > Model Specific Forums > RD, GK, and New Tiburon


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome