Hyundai Forum: Hyundai Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have an 04 Hyundai xg350. 160k miles. Need to get it registered and can't do so without it passing an inspection. I've had this car for a year and it's always drove great. I have a check engine light so I take it over to autozone have them do their test. He tells me I have a small emission leak, something about gas cap... but cap seems fine. I figured I'd change the wires just as regular maintenance,also in hopes of squashing that check engine light. First of all I changed the spark plugs i'd say about half a year ago. didn't mess with the wires at that time. So I get from autozone a duralast wireset for my vehicle, since they had them in stock and didn't feel like waiting for a package. At that time they didn't mention it's required to have the duralast ignition coil boots with it. Also in my mind I was like nahhh to getting new coils and figured itd still be good with the old ones. After the first wire change car misfired. I double, triple, even quad checked the make sure I have the wires in the correct order. After that I was think why the heck would it do that. so I did the process again and put my old plug wires back on. Still misfiring....... So i'm thinking like what the heck is going on. Today I went back to autozone and told them about it thinking I might have the wrong wires for my car...and they said oh you need the required coil packs for those wires. So I just say screw it and buy all new spark plugs ( bosh double plat or whatever) got those coils I needed for that wireset. i do the whole job today those wires, igniton coils, and plugs. still misfiring...... WHy the heck is this such a pain in the butt? Swear it takes 2+ hours for the job because i have to get the intake out before i can reach the plugs. Have had to take that intake off 4 times in the past couple weeks.
Anyways, uhhh the firing order autozone gives me is

rear of car
135
246
front of car
2-5 1-4 3-6
that's correct right?

Guys any help would be appreciated been out of a car for 2 weeks because of it. car functioned fine intil i put those new wire sets.
Really angry because i feel like it shouldn't be this difficult to change some plugs and wires.
 

·
Registered
Joined
·
3 Posts
did u ever fix you problem im having a simalar one right now i have a a hyaundai x350 2002 im tryna change the plugs & wires what all did u have to get and what is the intake? do i have to take that off on mine too?
 

·
Registered
Joined
·
1 Posts
You might want to use NGK or Denso spark plugs, some Hyundais don't like Bosch for some reason.
As a personal rule, Bosch is only for German cars. Put what came from the factory! I also do not trust anything electrical from Autozone.
 
1 - 4 of 4 Posts
Top