Hyundai Forum: Hyundai Performance Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
My car has started to act weird the last few days, under acceleration, in mostly 1st and 2nd gear I get a weird hesitation / jerking motion, almost like something is slipping for a split-second.
Now i'm going to get a new clutch put in Monday and I spoke to the tranny shop but they don't think its anything to do with the tranny.
I think it may be electrical, maybe the plugs and wires as I haven't changed them since I got this car a few weeks ago and they may just be old.
I have no warning lights on in the car and I just had the timing belt and all other belts changed two weeks ago.

Any other ideas on what I could check?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #2 ·
Well, its getting worse, now i'm losing power as the hesitation grows longer and the car misses more, I am going to start with the basics first, run some fuel injector cleaner, clean the throttle body and replace the fuel filter, then on to the plugs and wires if that doesn't work.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Hmmm, got bosch platinum+ plugs but no one had wires, got a fuel filter but need to remove it with the car in the air.
So I replaced the plugs, took the car for a drive and it worked perfectly! Imagine, just a plug going bad!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
Don't know how old they were but by the look of the wires, they may have been originals :0
 
1 - 6 of 6 Posts
Top