Hyundai Forum: Hyundai Performance Forum banner
1 - 20 of 34 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
i been playing with my 92 excel and have fitted extractors and removed the maf sensor and i had to adjust the throttle screw and the throttle position sensor to eliminate flat spots
and then i drove it . wow what a differance
now it pulls 50k in first and 90k in second and what a beautiful induction note the engine is so much more free reving <img src=/images/forums/snitz/thumbup.gif width=25 height=18 border=0>


<hr noshade width=60% size=1 align=left>
 

·
Registered
Joined
·
55 Posts
wow, I ran the X2 EFI setup on my X1 and when I removed the MAFS it barely ran at all. Wouldn't idle, wouldn't rev very well, threw a CEL and several codes with it.

I think it was in 'limp home mode'.

What exactly did you do to get it driveable?


<hr width=60% noshade size=1 align=left>
 

·
Registered
Joined
·
81 Posts
I have a 92 Excel...got told I couldn't get a high flow filter for the car that would go in without a fight, ie; cutting something or stuff like that.

What did you do to the car EXACTLY...as I likes the sound of my car running better like yours! <img src=/images/forums/snitz/thumbup.gif width=25 height=18 border=0>


<hr width=60% noshade size=1 align=left>
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #4 ·
ok heres what i did and why
first thing i did after fitting extractors and a free flowing straight through muffler was to remove the airfilter resonators (the external plastic pod and the internal metal cage and paper star sound adsorbtion thing )
then i wrapped the extractors in fibre-glass thermal tape then i thought how can i get this little baby to pull harder, so i then looked at the maf (mass air flow sensor) and noticed that the was two holes underneath the maf sensor but one was blocked from factory, this is because a certain amount of air must
pass through the maf or the car will not go
properly (if the maf can't sense air it wont give fuel) so i thought i would put some soft
foam in the open hole under the maf so nearly all the air has to pass though the maf sensor . WOW this was on the right track the car pulled so much more
harder down low and in mid range and did not lose to much top end, so then i marked the position of the throttle postion sensor then proceeded to treat it like a mixture screw with good results from stoping black (rich)smoke i drove the car like this for about month with no problems starting cruisin or full throttle i was almost go to stop there ,man this thing was flying, but coz i had an alfa gtv years ago i just felt i wanted a bit more top end rpm in the excel so i knew the maf sensor was the biggest retriction in the inlet track so i un- plugged it and took it right out all there was left was the black hose from the throttle body
so i turned the key she ran like a dog rich as buggery so then i started by rasing the idle screw so it would idle but rough, then i backed off the throttle position sensor (the one on the throttle body)so the car would run smooth then a little bit of road testing found only slight movement of the thottle position to clean up smoothness , so i came home and unscrewed the maf from the air box lid and stuck the lid and filter back on and taped up holes for now,
when driving the car now it still starts good but you can feel the motor is like only on half choke insead of full choke when cold in morning but when the car is warm its perfect in every way ,
the car now feels like it can rev to the moon ,
down side is little bit worse fuel economy but still worth the trade off (you dont make horsepower and not use fuel?)soon i will take off head and intake manifold and give them a mild port job to increase air speed the trick is not to go bigger just smoothen flow (fast stream not slow river)so i hope this helps i was told it can't be done, but hey mine goes great!!<img src=/images/forums/snitz/thumbup.gif width=25 height=18 border=0>


<hr width=60% noshade size=1 align=left>
 

·
Registered
Joined
·
1,020 Posts
We've been trying to solve this damn MAF for years now! I did the same as Xlr8 and ported out one of the holes. It ran like junk. It would almost die when you stomped on the gas. I disconnected the MAF and the car would die when you give it gas. So we've all come to the (cut the airbox DIY CAI). I don't trust playing around with to much of the car myself. I'm not going to experimentive because its my daily driver and don't want to hurt the car. I'm don't know a whole lot about engines either. Tell us what is like if you can track test it. I would like to compare 1/4 mile times if it makes a difference and 0-60mph times. This is an out stretch but if Dyno is possible we would all like to know what the HP in crease will be and if it won't hurt the engine. Other than that I think that sounds awesome, and it if works, many of us will be doing that.


<hr width=60% noshade size=1 align=left>Timothy Zacher
1991 Excel Evo II Rally Project
#346 N
Des Moines, WA
http://www.geocities.com/nwhec/
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #6 ·
like i said i didnt think i would get away with it but i did , you should all try blocking the holes
under the maf first and make all air go thru maf that was my first experiment to get more fuel in, dont worry about top end rpm so much just feel how she pulls down low and in midrange, then if you feel like being adventurous go and un-plug the maf and start playing have fun(ps i willl dyno the excell after the head and manfold are finished ok see ya)<img src=/images/forums/snitz/thumbup.gif width=25 height=18 border=0>


<hr width=60% noshade size=1 align=left>"a closed mouth gathers no feet"
 

·
Registered
Joined
·
328 Posts
got any pics of the set up and what you did to the MAF?


<hr width=60% noshade size=1 align=left>put a S.O.H.C in it!!!
 

·
Registered
Joined
·
81 Posts
I plugged the 2nd hole under my MAF. Yes, I noticed a difference. It does pull harder low end and mid. I was impressed that something that only required about 2 mins worth of work and a piece of foam would give me something useful back<img src=/images/forums/snitz/smile.gif width=15 height=15 border=0> If you other guys plug the hole too, you should notice a diff...please keep me posted if you have any other ideas similar to this for the x2! Thanks guys<img src=/images/forums/snitz/thumbup.gif width=25 height=18 border=0>


<hr width=60% noshade size=1 align=left>
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #9 ·
see i told you? theres more fun to be had, all mod's i have done can be reversed, so think how you can fool the efi system to do things you want it to do <img src=/images/forums/snitz/thumbup.gif width=25 height=18 border=0>


<hr width=60% noshade size=1 align=left>"a closed mouth gathers no feet"
 

·
Registered
Joined
·
81 Posts
You told me yeah, but damn! Why does my car keep dying? It has never died like this b4. I turn it over and it revs like it's been sitting there for weeks then shuts off. This AINT good. IF it is cause of my blocked hole, then blow that I'm takin that sucker out. Surely it can't be good for the car <img src=/images/forums/snitz/guns.gif width=33 height=16 border=0>


<hr width=60% noshade size=1 align=left>
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #11 ·
try adjusting throttle postion sensor +/_ ..or disconnect battery for 30 mins <img src=/images/forums/snitz/thumbup.gif width=25 height=18 border=0>


<hr width=60% noshade size=1 align=left>"a closed mouth gathers no feet"
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #13 ·
also check your throttle body butterfly size ?
i do believe there are 2 different sizes , iam still not 100% sure why mine works so well,(load , cruise ,full throttle, starting)
i hope everybody the best of luck ,but i do not know all the chages hyundai makes between
U.S and Australian cars so please do these mods at your own risk!


<hr width=60% noshade size=1 align=left>"a closed mouth gathers no feet"
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #14 ·
my throttle body butterfly is 48 mm approx


<hr width=60% noshade size=1 align=left>"a closed mouth gathers no feet"
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #15 ·
theres one thing i forgot to say , that the check engine light stays on.( but you guys allready know that now)<img src=/images/forums/snitz/thumbup.gif width=25 height=18 border=0>


<hr width=60% noshade size=1 align=left>"a closed mouth gathers no feet"
 

·
Registered
Joined
·
81 Posts
My car is Aussie too. So, it should be the same as yours with the size of the butterfly.

I am gonna d/c the battery for a bit tommorrow and that should do it.<img src=/images/forums/snitz/wink.gif width=15 height=15 border=0>


<hr width=60% noshade size=1 align=left>
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #17 ·
this thing is still flying along , and i do recomend these mods if you own a 92 excell(x2) my fuel consumption is 220ks/19lt and thats not taking it easy, hopefully in the next 2 weeks ill get time to take the head off and flow the ports , this thing has so much power just waiting to be tapped . see ya
<img src=/images/forums/snitz/thumbup.gif width=25 height=18 border=0><img src=/images/forums/snitz/smile.gif width=15 height=15 border=0>


<hr width=60% noshade size=1 align=left>"a closed mouth gathers no feet"

Better to be thought to be an idiot? than to open your mouth and take away all doubt!!!!
 

·
Registered
Joined
·
6 Posts
Hey, I have a 91 Excel, i did what you guys did and plugged the hole on the bottom of the mafs. It worked like a charm. that puppy is pullin some major low end power. But, i want more. can you be more specific on how to do the next step on taking the mafs out. Also, is thier any other little secrets that can help me out to get more performance???


<hr width=60% noshade size=1 align=left>Hyundai is just a New Found Performance!!!!
 

·
Registered
Joined
·
81 Posts
"hopefully in the next 2 weeks ill get time to take the head off and flow the ports , this thing has so much power just waiting to be tapped . see ya"



please explain the process of flowing the ports...THANKS!!!<img src=/images/forums/snitz/wink.gif width=15 height=15 border=0>


<hr width=60% noshade size=1 align=left>
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #20 ·
when you first unplugg the mafs the car runs horrible ,but thats the only time it will.
ok unplugg the mafs then turn up the idle screw so the thing idles but rough then mark the throttle postion sensor so then you can tell how much you have moved it ,turn the tps counter clockwise until the idle is smoother then go for spin you still might need to do some fine tuning carfully turn tps clockwise or anti clockwise half a millimetre at a time until you get it right then raise ignition timming 2 degrees. to answer the other question about flowing ports the trick is not to go bigger but to remove all burs and iregularities (remember fast flowing stream not slow moving river)but all thats on hold until i fit this supercharger, then off comes the head for a port job and some lower comp pistons then all the fun begins. make sure you read all previous posts on this subject and i wish you all luck that i had
<img src=/images/forums/snitz/smile.gif width=15 height=15 border=0><img src=/images/forums/snitz/thumbup.gif width=25 height=18 border=0>


<hr width=60% noshade size=1 align=left>"if work was good for you the rich would leave none for the poor"
 
1 - 20 of 34 Posts
Top