Hyundai Forum: Hyundai Performance Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
307 Posts
Discussion Starter #1
OK, I'll show you the pics first, and then give you the lowdown.

<img src="http://members.tripod.co.uk/Xorro3/ukhcs/mine/mine105.jpg" border=0>
<img src="http://members.tripod.co.uk/Xorro4/ukhcs/mine/mine106.jpg" border=0>
<img src="http://members.tripod.co.uk/Xorro4/ukhcs/mine/mine107.jpg" border=0>
<img src="http://members.tripod.co.uk/Xorro4/ukhcs/mine/mine108.jpg" border=0>
<img src="http://members.tripod.co.uk/Xorro4/ukhcs/mine/mine109.jpg" border=0>
<img src="http://members.tripod.co.uk/Xorro4/ukhcs/mine/mine110.jpg" border=0>
<img src="http://members.tripod.co.uk/Xorro4/ukhcs/mine/mine115.jpg" border=0>
<img src="http://members.tripod.co.uk/Xorro4/ukhcs/mine/mine116.jpg" border=0>
 

·
Registered
Joined
·
307 Posts
Discussion Starter #2
<img src="http://members.tripod.co.uk/Xorro4/ukhcs/mine/mine117.jpg" border=0>
<img src="http://members.tripod.co.uk/Xorro4/ukhcs/mine/mine118.jpg" border=0>
<img src="http://members.tripod.co.uk/Xorro4/ukhcs/mine/mine119.jpg" border=0>
<img src="http://members.tripod.co.uk/Xorro4/ukhcs/mine/mine120.jpg" border=0>
<img src="http://members.tripod.co.uk/Xorro4/ukhcs/mine/mine121.jpg" border=0>
<img src="http://members.tripod.co.uk/Xorro4/ukhcs/mine/mine122.jpg" border=0>


OK, as you may have guessed, this is the Alpine Supercharger, which I had installed about a month ago.

Unfortunately due to some of the components not fitting correctly the install took the best part of a week, so as you can imagine the labour costs were almost as much as the s/c itself.

My local Motorsport place that does all my work carried out the install, so I know that they are competent folk. At the moment I am communication with Alpine about the ill fitting components and I am hoping to get some kind of compensation back from them. John the owner of Alpine will be in the UK soon and will be coming over to talk to me and the motorsport guys about the problems they had. Needless to say most of the time was spent trying to machine the pulleys and their brackets so that they all lined up nicely.

Anyway the good news is that the supercharger is great. It doesn't give the 'instant power' I was expecting, the power seems to 'come on' around 3000rpm, with another extra 'boost' around 4k then 5k.
The car revs quite freely now and will happily readline in 2nd gear. (85mph @ 6500rpm)

At the moment I am not running the 5th injector or the Unichip. And surprisingly I am not having detonation issues.
Although Alpine did supply the injector and chip they advised the motorsport company that they were not needed as I am running a MAP sensor. This area is a little confusing as Alpine wanted to know whether I am running MAF or MAP so that the chip could be programmed!! I am currently looking to take the injector and chip to a Unichip expert to see what magic, if any he can do.

I haven't had the car dynoed yet, but this should be done when it goes to the Unichip guy, which should be within the next month.

The last dyno I had done was after the ICON superchip and the induction system, and I was putting out 157bhp @5527rpm and 201nm @ 5344rpm. So it will be interesting to see the figures on the next dyno run. I will have to bear in mind that as well as having the s/c fitted since the last dyno, I have also had the cams, bbtb, rebore, header and exhaust! BTW, the ICON is not installed at the moment, but if the Unichip is a no-go I will look at having it put back in.

Zorro

PS If the pictures disappear due to crappy Tripod I will re-upload them the next working day.
 

·
Registered
Joined
·
14,259 Posts
damn xorro, you've been busy, how much did the sc run you? looks great.

<img src="http://63.102.174.92/rudy_mini2.jpg" border=0>
my car is yellow. [email protected]
 

·
Registered
Joined
·
21,319 Posts
<b>DR<img src=icon_smile_tongue.gif border=0 align=middle><img src=icon_smile_tongue.gif border=0 align=middle>LL</b>

<img src="http://www.transfans.com/logospin.gif" border=0><img src="http://www.coreyandjayshow.com/pee.gif" border=0><img src="http://www.hyundaiperformance.com/upload/binladen.jpg" border=0>
 

·
Registered
Joined
·
8,316 Posts
Very nice.

How far off were the parts from not fitting? Was it just a little off or did it look like they were made for a completely different car?

<img src="http://63.102.174.92/upload/4doorGLSig.gif" border=0>
 

·
Registered
Joined
·
693 Posts
Nice!!!!!

<img src="http://animations.fg-a.com/domincnC.gif" border=0>
www.geocities.com/decrum1
 

·
Registered
Joined
·
423 Posts
mmmmmmmmmmmmmmmmmmm!! POWER!!!!!!!!<img src=icon_smile_big.gif border=0 align=middle><img src=icon_smile_big.gif border=0 align=middle><img src=icon_smile_tongue.gif border=0 align=middle>
 

·
Registered
Joined
·
1,285 Posts
Xorro,that looks sweet man.I got the Alpine Turbo kit but im going to install it in the spring of next year.Im also not using the unichip thats provided with the kit.I already have a S-AFC and 440cc injectors.This should defently work better than the unichip!
 

·
Registered
Joined
·
26 Posts
Xorro,
It is great to see an installation of a supercharger, and to know the issues that have come about. I too im interested installing one in my 2001 tib. What is the cost on the install and the unit, approx?
 

·
Registered
Joined
·
35 Posts
It's great to see that girls are moddifying their cars.....!!<img src=icon_smile_big.gif border=0 align=middle>

Keep it un xorro..<img src=icon_smile_big.gif border=0 align=middle><img src=icon_smile_big.gif border=0 align=middle><img src=icon_smile_big.gif border=0 align=middle>

Elbert..<img src=icon_smile_cool.gif border=0 align=middle>

91 Excel HB 1.3 w/T02 Turbo....

"The Honda Killer"
 
1 - 12 of 12 Posts
Top