Hyundai Forum: Hyundai Performance Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 · (Edited)
Accent Hydraulic Valve-Lash Adjusters (HLA) Cleaning

I own a Oct, 2003 model 1.5L 12V SOHC Accent. Lately, I noticed that there is some sort of tapping noise in the engine. My mechanic adviced that I should get my HLAs (Hydraulic Valve-Lash Adjusters) cleaned. I really wanna clean the HLAs myself. I found this great link which shows how to clean HLAs

HLA cleaning

Now the only problem is, locating the HLAs. Can someone help me by telling me where are they located exactly and how to disassemble them? Any precautions etc to be taken. If possible, please post a pic for me, to help understand things better.

Link for disassembling HLAs for a subaru.
Untitled Document
 

·
Registered
Joined
·
737 Posts
your going to have a hard time cleaning them since you would have to unbolt your valvetrain just like in the subaru article. To thoroughly clean them they would need to be out of the head and even then the problem can come up again once they get gummed up again. It's a bigger job then most people are willing to tackle. I've never had my valvetrain apart so I can't walk you through it, but this might help with getting to them.

http://www.alldatapro.com/alldata/PRO~V69505574~C44204~R0~OD~N/0/77993956/78323374/78323384/128644180/34853741/100411974/34853743/34854590/34849578/107605533

i'm not sure if this link will work for you but it explains taking out the rocker arm assembly to get to the hlas
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
andy said:
your going to have a hard time cleaning them since you would have to unbolt your valvetrain just like in the subaru article. To thoroughly clean them they would need to be out of the head and even then the problem can come up again once they get gummed up again. It's a bigger job then most people are willing to tackle. I've never had my valvetrain apart so I can't walk you through it, but this might help with getting to them.

http://www.alldatapro.com/alldata/PRO~V69505574~C44204~R0~OD~N/0/77993956/78323374/78323384/128644180/34853741/100411974/34853743/34854590/34849578/107605533

i'm not sure if this link will work for you but it explains taking out the rocker arm assembly to get to the hlas

I know I'll have to take off the valve train, I even tried taking off the cover yesterday... anyhow, I tried opening the link you provided, it requires registration. I think it's paid... Can you post that article in this forum?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #4 · (Edited)
HLAs Figured out!

So finally I took the risk of opening the valve train cover and unhooked the Rocker Assembly and cleaned the HLAs. All my 12 HLAs were jammed. But now that I have cleaned them, the engine sounds a lot smoother.
Attached is the pick which would help you guys locating and unhooking the HLAs
Green Circles are the HLAs
Red Arrows are the screws you need to unscrew to take off the rocker assembly

Before Cleaning


After Cleaning
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #6 ·
187sks said:
Nice job. Looks like your radiator hose could use replacing soon too.
The hose is not broken, its has a cozting of something, which has cracked... anyhow I have replaed the hose already!
 

·
Registered
Joined
·
13,145 Posts
That's good. Usually once that coating goes it leaves the hose weak there and it will rupture eventually when under pressure, often times leaving you stranded somewhere you don't want to be.
 

·
Registered
Joined
·
737 Posts
sorry to get back to you so late, i've been busy at work and didn't get a chance to get you the info. Good to see that you tackled it and everything came out for the better. Most people aren't willing to dive right in and start taking apart valvetrain components. I might have to take mine out and clean them on my turbo car since its been sitting for awhile.
 

·
Registered
Joined
·
103 Posts
Okay so what did you use to clean them with?. and how hard was it to take the components out (or did you clean it in place?). Do the lifters just pop off or is there a procedure for taking them off. My valves are staring to get quite noisy, figured id give this a try
 

·
Registered
Joined
·
596 Posts
I thought you could use a bit of seafoam in the motor oil to clean them out...
Like run the modified oil for a 100km then change it completly...

I left my car sitting still for about a week and a half not too long ago when it was broken into and i was waiting on quote for reparation of the damage...
Man did it shudder...
Got over it in about 30 sec but still, damm, i was like WTF now what!?!?...
Since then i never leave my car sitting still for more than 24hrs...





Cheers
scythe
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #11 ·
spazzout said:
Okay so what did you use to clean them with?. and how hard was it to take the components out (or did you clean it in place?). Do the lifters just pop off or is there a procedure for taking them off. My valves are staring to get quite noisy, figured id give this a try
I used paint thinner to clean them up. It's better than petrol when it comes to cleaning. Taking out the components was very easy, you need to have a No. 10, 12, 14 and 17 to deal with all the nuts. Once yo've taken off the nuts for the rocker assembly, all u need to do is pull it out, as simple as it sounds!
Cheers
Have fun cleaning it all!
 

·
Registered
Joined
·
103 Posts
thanks. . . eh did you replace the valve cover gasket at the same time or is it a silocone type deal?
 

·
Registered
Joined
·
737 Posts
replace the valve cover gasket at the same time
 

·
Registered
Joined
·
1,965 Posts
I pulled my valve cover off and I don't think the beta 2 motors have this hla. Must be a sohc thing?
 

·
Registered
Joined
·
5,294 Posts
How long did this take you?

I'm assuming you didn't have to take the rocker arm assemblies apart, just out of the head, correct?

I have one that is getting worse and don't really feel like spending 30 per to replace them all.
 

·
Registered
Joined
·
6,330 Posts
I pulled my valve cover off and I don't think the beta 2 motors have this hla. Must be a sohc thing?
my beta lc make's alot of valvetrain noise..

everytime i give it some gas..the enigne make's a mild knack.knack.knack sound..

i talked to one of my tech's and he suy's it's the shim's that are getting worn out..shim's are like little thick metal disc's between the valve and the camshaft lobe..he said to gte a feeler gauge and slide it in the gap between the shim and the lobe..if it doesn't slide in..the shim's are nice and tight

if the feeler gauge slide's in easily or just slides..the shim's are worn..

i'm planning on doing this myself..i'm gonna buy a new set of oem shims, a feeler gauge, and a thickness gauge..i'm also thinking of porting the intake manifold and the heads and install larger injectors along with a new set of high lift cams..try it make the beta 2's valvetrain run better and hock up some horsepower
 
1 - 18 of 18 Posts
Top