Hyundai Forum: Hyundai Performance Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
718 Posts
Discussion Starter #1
Hey i'm huntin trying to find a a-pillar pod set for my x3 to hold 3 guages but i cant find ANY pods for the x3 WTF is there another car that has the same a-pillars? Or who sells the x3 pods? Any help i'd greatly appreciate
 

·
Registered
Joined
·
718 Posts
Discussion Starter #2
People hate helping me LOL :(
 

·
Registered
Joined
·
490 Posts
its not that, just a quick search would point out that they dont exist for your car and that you will have to "remold" a set from a civic to fit your car.

i dont know the specifics, do a search on the subject
 

·
Registered
Joined
·
718 Posts
Discussion Starter #4
Damn what is it with the x3 is it like the outcast car i mean shitty old kia vans have euro lights and the x3 doesnt, now no apillars? LMAO lol.
 

·
Registered
Joined
·
490 Posts
i miss my old 99 x3 :)

of course nothing was available for it, but hey that just guarantees your car's uniqueness :)
 

·
Registered
Joined
·
616 Posts
i got a pod for a 95 civic off of ebay for $25 went to the local hardware store got a fiberglass kit for $10 and made one... its very easy and take about 2 hrs.... heres a pic before it was painted...



i got paint to exactly match the pillar from a hardware store.. after paint looks just like it was molded for our cars... cant tell any flaws.. just be sure to sand it really well so you dont see any pits or scratch marks.

[Edited by matt1840 on Sep 30, 2004 6:14 PM]
 

·
Registered
Joined
·
47 Posts
seems like alot of work for 2 gauges that are useless. something tells me you dont have use for that boost gauge. put in some usefull gauges, oil an temp always work. thats what i used
 

·
Registered
Joined
·
427 Posts
I gave up trying to find or make a pillar pod, so I took out the vents in the dash (which I never use anyway) and put my guages there.
Take a look in my profile.
(I can't figure out how to add a pic to the message):ermm:
 

·
Registered
Joined
·
616 Posts
seems like alot of work for 2 gauges that are useless. something tells me you dont have use for that boost gauge. put in some usefull gauges, oil an temp always work. thats what i used


boost gauge? thats a vac gauge dude... and yeah i do have a turbo setup for my car.. not complete yet but i do have one. all i need is the fmic and get some piping bent up... i dunno if youve looked in my profile but i have an extensive amount of work done to my car.
 

·
Registered
Joined
·
2,636 Posts
There you go Platinum.......looks really nice! :-


Props!
Nick:)
 

·
Registered
Joined
·
580 Posts
Originally posted by Platinum6316
[body]
so I took out the vents in the dash (which I never use anyway) and put my guages there.
[/body]
looks nice. did you take any pics during the installation?
 

·
Registered
Joined
·
427 Posts
Sorry, no. But it was fairly simple.
I just had to remove the Speedo guage pod, and the glovebox.
The hardest part was cutting the venting in behind the dash with a hacksaw blade.
After that was cut, I removed the vents by unscrewing them from the dash and taped the vent where it was cut, so the side vents still work.
I cut a piece of sheet metal to fit the space, then drilled 2" holes for the guages.
drilled the holes in the corners for the screws to fit in the spots where the vent was attached. Spray painted the sheet metal with a Satin Finish Black. Ran the Oil line, the Ammeter Lines, attached the Voltmeter and Lighting lines to the wiring behing the Speedo Guage. then re-installed the speedo guage and glovebox.
The only flaw is that the sheetmetal doesn't curve properly to blend in with the dash, however it's just a minor visual flaw.
Platinum6316.
 
1 - 17 of 17 Posts
Top