Hyundai Forum: Hyundai Performance Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
257 Posts
Discussion Starter · #1 ·
OK I just picked up a 96 Accent, 2 door with the 1.5L SOHC motor, automatic. I have been a Tiburon guy for years so I am not very familiar with this car or motor.

The car had a CEL and it was showing misfires. Every cylinder and random, multiple cylinder codes. The car has newer plug wires, coil pack and I just replaced the fuel filter. I am looking for any ideas on what could be the problem.

When stopped at a light or stop sign it is VERY sluggish off the line and really has no power at all. Horrible gas mileage.

Now, I am a technician at a shop here so parts arent a big deal. I am thinking possibly the O2 sensor and it just didnt throw a code. I just am trying not to put to much money into random parts since I got the thing for dirt cheap. I just want it to run right and get me some good gas mileage. Any ideas or tests you want me to do would be helpful and I can get any info needed. A little under 100k on the odometer. Thanks guys
 

·
Registered
Joined
·
686 Posts
try a new maf, that was my problem
 

·
Registered
Joined
·
67 Posts
What about a timing belt mess up?
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #4 ·
I was considering that. But Im waiting for maintenance records so I can see if its even had one. The maf seemed to be reading ok but I will double check the voltage Im getting out of it. Thanks and keep ideas coming.
 

·
Registered
Joined
·
147 Posts
..

well u get what u pay for...
 

·
Registered
Joined
·
1,880 Posts
g4ebguyGTX said:
well u get what u pay for...
Oh shut up, troll.

If you don't have anything helpful to add, just don't post.
 

·
Registered
Joined
·
147 Posts
well think about it stupid ass... he said he payed dirt cheap so he got something worth dirt cheap and in that part that suffered reliability....kinda like buying a prostitute
 

·
Registered
Joined
·
398 Posts
first of all sir I am a prostitute and I am outraged.....ok i'm kidding.
Nah don't start a pissing contest please....and he's correct -helpful or post in the troll section. (theres not one)

But I do agree that you get what you pay for......since Hyundais are dirt cheap brand new though;i expect them to be dirt cheap at all levels of age......

Last: My car was sluggish just like yours ....i found what was wrong with mine. (104 horse power)

Good luck with ur car bro.

Marcus
 

·
Registered
Joined
·
3,276 Posts
I would check the voltage on the tps, o2 would definitely throw a code. If the codes only show misfires then its a plug problem. TPS would likely throw a code but at times may not...
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #10 ·
OK I found the problem. The Fuel Pressure regulator had the diaphragm messed up. What was happening was the fuel was coming through the vacuum line into the Intake manifold, making it run super rich and flooding while stopped. The quick fix while I was waiting for the new FPR was to cap off the top. This is ok to do because of the return system will return what the fuel injectors dont use. It is not a permanent fix.

The car is running great now but has developed a small knock from the gasoline getting into the oil. When I drained it you could actually light the oil on fire. I am hoping this is just a carbon knock that will work itself out in time. It should be reliable enough for me for a while.

And I paid 100 for the thing and I have put maybe 100 in it just with doing some small stuff. Im alright with that though. Thanks for the input guys.
 
1 - 10 of 10 Posts
Top