Hyundai Forum: Hyundai Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Ok strange new problem with this car now, everything is working great (minus the busted maf sensor which i am waiting on the replacement) except now a wierd wiring issue im assuming has come up. When i turn on my left turn signal while the car is running it blinks really fast and my dash lights blink with it, the right turn signal does not do this at all. when the car is off both work without ne problems. now when the head lights are turned on and i switch on the turn signal it goes really slow and my engine starts to stall out (possibly because the maf sensor is currently unhooked?) even with just the headlights on and the blinker off the left green arrow in my cluster stays constantly lit, but very dim. could someone tell me if this is a problem with maybe a relay somewhere or is this simply a wiring short somewhere? any ideas will be greatly appreciated!
 

·
Registered
Joined
·
43 Posts
check the bulbs.... i once bought the wrong bulbs and when i put the left or right blingker it looked like i had my emergency lights.. also my dash lights would bling as well
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
all my bulbs are correct the wierd thing i noticed now is when the car is in reverse the dash lights come on dim so im thinking now it has something to do with the tail lights because it also does it when you apply the brakes, could this be a tail light relay or something?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #4 ·
Ok problem solved, it ended up being a lose ground wire in the trunk on the left side above the rear strut tower, tightened it down and problem went away. probably one of the easier problems ive had to solve on this car lol. thanks for the tips guys!
 
1 - 4 of 4 Posts
Top