Hyundai Forum: Hyundai Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
Hi guys !

My car broke down this morning on the way to work. She started jerking yesterday/erratic idling/revving up on her own. For the first 30 km's of my 54 km trip to work, she ran normally, and then started to jerk, had my foot flat down but no rev whatsoever (just a loud induction noise), and then eventually died off. Tried starting , just swings, does'nt take, and sometimes idles for a second or so and died off, would'nt take gas even when I tried pumping the accelerator. For the past 3 weeks or so the car does'nt start when hot, just swings, I would usually have to wait for 10-15 minutes before trying again and then with slight hesitation and petrol fumes shes starts up, usually followed by white-ish smoke from the exhaust. BTW I replaced the starter when i bought the car 2 months ago. Well to cut a long story short, I think the problem this morning was dirty fuel, cos I eventually started the car after filling in 5 litres fuel and she drove perfectly after that, then again 20 litres and she ran perfectly to my workplace. I am nervous about the drive home cos I usually sit in traffic and cannot afford to get stuck....AGAIN. I believe Neville from South Africa was also having similiar erratic idling/starting problems with his Scoupe GT and after chatting with him , he said it was cured by some sort of repairs to the MAF.

Guys, any help/advice will be highly appreciated.
:depressed:
 

·
Registered
Joined
·
468 Posts
When was your fuel filter last changed? My car started coughing and spluttering heaps just suddenly about 2 weeks ago after not changing the filter for 2 years... i REALLY shoulda changed it earlier. but it was like full of mud and when it was changed my car was good as.... hope that helps.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #3
Hi Tweak

I changed the fuel filter at the last service, 9000 km's ago.
So I've ruled that out as a possibilty of being the problem.

:puzzled:
 

·
Registered
Joined
·
53 Posts
Discussion Starter #4
I changed all the filters including the fuel filter when I bought the car (9000 km's ago), so I have ruled that out as a possible cause.
Next week, I'll take it to the dealership for them to do a check/hi-scan.
Anyways, the drive home yesterday went well, no hassles at all. I refilled the tank, so I am hoping it was just dirty fuel.
Well to add to my list of problems, the car is smoking now and again, and I checked for play in the turbo, well there is some play on the wheel and a bit of oil at the intake, although I think thats from the tappet cover breather pipe ?
Been doing some research on getting a recon T25 originally from a Nissan and that wont cost and arm and a leg (I believe they bolt straight onto the flange).
Can I make an educated guess and say that the occasional white smoke means it time for new piston rings and valve stem seals? :puzzled:
 

·
Registered
Joined
·
67 Posts
The problem with my car wasn't the turbo, but #4 pistons obviously rings or piston. It use to smoke also occasionnally but not all the time at the end of it life. I always found a "film" of oil in the intake near the turbine ever since new, so it kinda normal. Have you check your spark plug are any of them have a built up? My #4 use to have alot! but the other 3 were fine.

A snap on scanner (or any other type of code reader) can identify any trouble code. My 93 scoupe turbo didn't have a engine trouble light in the dash it was tape up but the 94 N/A did (just a light bulb). So I suggest find a garage with a "code reader" to diagnose the problem, I think you have a sensor problem and if I had to guess from your symptom I look first at your crank sensor. It located infront of you engine on the transmission above the clutch slave cylinder, it black and round and take it reading fromt the flywheel.

Dan
 

·
Registered
Joined
·
67 Posts
Also check all intake rubber for any crack between the MAF and the turbo cause oil, in time, will eat away at the rubber. Also when you can't start and have to wait 15 min. is the IAC humming when you have your KOEO?

Dan
 

·
Registered
Joined
·
53 Posts
Discussion Starter #7
Originally posted by turboS
[body]
Also check all intake rubber for any crack between the MAF and the turbo cause oil, in time, will eat away at the rubber. Also when you can't start and have to wait 15 min. is the IAC humming when you have your KOEO?

Dan
[/body]
Hi Dan

I'll check the sensors out as soon as possible.
As far as i know, in South Africa, only Hyundai have the equipment to analyse the fault codes, and yes my Scoupe also does'nt have the Engine check light. Its probably also taped up somewhere behind the instrument cluster.
Yes IAC is humming when I have KOEO.

;):
 

·
Registered
Joined
·
2,636 Posts
Hi again!......I can`t remember if I`ve said before, but the rising/falling of revs. at idle on a warmed-up engine is a definite throttle position sensor fault, which, I`ve heard, won`t show up on the Hi-Scan device.

Disconnect the plug, clean with a suede brush, take the sensor out of the throttle body (2 screws) & clean it & the inside of the t.b. with spirit......this often cures the fault, but a new sensor is `only` about £60 Sterling.

Cheers,
Nick.:)
 

·
Registered
Joined
·
53 Posts
Discussion Starter #9
Originally posted by VALKYRIE YB70
[body]
Hi again!......I can`t remember if I`ve said before, but the rising/falling of revs. at idle on a warmed-up engine is a definite throttle position sensor fault, which, I`ve heard, won`t show up on the Hi-Scan device.

Disconnect the plug, clean with a suede brush, take the sensor out of the throttle body (2 screws) & clean it & the inside of the t.b. with spirit......this often cures the fault, but a new sensor is `only` about £60 Sterling.

Cheers,
Nick.:)
[/body]
Thanks Nick
You did mention it , I have tried to remove the TPS to clean it, but the 2 screws that hold it to the throttle body seem to be seized, I was unable to remove them and I was afraid I might strip the heads of the screws.
Any ideas on how to get them loose ?
 
1 - 9 of 9 Posts
Top