Hyundai Forum: Hyundai Performance Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter · #1 ·
Hey. I am finishing up my turbo setup and thought i would see if my car started using its almost dead battery. It started up and revved to 2500 then slowly dropped rpm's until it bogged out. everything is hooked up except the iac, the mbc is completely open meaning no boost, no exhaust hooked up to the dp and i think thats it. Anybody have any suggestions?
 

·
Registered
Joined
·
127 Posts
Well if you dont have DP then the exhaust gases never pass through the o2 sensors and that may be the reason it bogs down.
 

·
Registered
Joined
·
687 Posts
It could be a lot of things...

Without an exhaust hooked up, you might not have enough backpressure for a clean start, so that might be the issue with the initial bogging. Are any O2 sensors installed? Sounds like you might be running a bit rich, and that's why. Definitely take out your plugs and see if they're fouled. If they are, clean, reinstall and find figure out the fuel issue

Howie~
 

·
Registered
Joined
·
213 Posts
without the IAC, it will bog out also
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #6 ·
does anyone know if the IAC has to have air passing by it, or if it just needs to be surrounded by air to work? mine wont reach my charge pipe, so i was goin to connect flexible tubing from the charge pipe to the IAC. Would this work or does it have to be directly connected to the charge pipe? thanks.
 

·
Registered
Joined
·
7,118 Posts
So you opened your mbc all the way. Correct me if I am wrong but a mbc is a controlled leak. So it takes more pressure to open the waste gate. If you have it fully open..

A) your waste gate will never open so you could create boost, but not at idle so Ill leave this alone now.

and

B) If by open you mean you removed it completely, did you just create a rather large vacuum leak? That or if the opening on the mbc is large when fully open could this also create a vacuum leak large enough to piss the ecm off?

Does it run like total crap before it dies or does it just come to a stop after the revs drop from 2500?

That and/or get the known problem fixed before going any further into trouble shooting, that being the IAC.
 

·
Registered
Joined
·
3,276 Posts
As far as the iac i removed mine and plugged it at the intake manifold. HOWEVER, if you are going to keep it then it needs to run to the intake side of the turbo. When mine was seeing boost it started having all kinds of problems..... Your boost controller should be running in the vacuum line form the turbo nipple to the wastegate actuator...... If you think its the problem just bypass it, takes 2 seconds.
 
1 - 8 of 8 Posts
Top