Hyundai Forum: Hyundai Performance Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
423 Posts
Discussion Starter #1
My 1999 accent did something really weird today. I stopped to put gas in it and when I went to start it it had a hard time starting, now this happened b4 but it ran fine afterwards but this time it shooke as it was idling. Ne ideas??<img src=icon_smile_dissapprove.gif border=0 align=middle><img src=icon_smile_dissapprove.gif border=0 align=middle>
 

·
Registered
Joined
·
2,951 Posts
It was shaking because your engine wasen't getting enought fuel. or AIR. Check your intake sensor. and see if its dirty or on properly. If its your fuel you might need to replace your filter or clean you injectors.

-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
<img src="http://www.ballisticunlimited.com/koolart/images2/ford/P0640.jpg" border=0>
I'm a Ford Man With a Tuned Hyundai!
And for all you ricers out there! www.riceboypage.com Enjoy!
 

·
Registered
Joined
·
423 Posts
Discussion Starter #3
my check engine light has been on for about 3 months too. But sometimes it turns off for a few days then kicks back on
 

·
Registered
Joined
·
2,951 Posts
Yeah, Hyundais CEL are very sensitive.

-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
<img src="http://www.ballisticunlimited.com/koolart/images2/ford/P0640.jpg" border=0>
I'm a Ford Man With a Tuned Hyundai!
And for all you ricers out there! www.riceboypage.com Enjoy!
 

·
Registered
Joined
·
1,170 Posts
I agree with Lantra.

2000 Black Hyundai Elantra GLS
 

·
Registered
Joined
·
423 Posts
Discussion Starter #7
ya I changed the air filter not even a month ago so Im figurin it is either the injectors or the fuel filter
 
1 - 7 of 7 Posts
Top