Hyundai Forum: Hyundai Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #1 ·
There are many topics with the same title, but can anyone tell me what to do after unpluging and reconecting the Negative battery wires. How many KM's Miles do i have to drive and at what speed?

in the nissan forum they describe it as

leting the switch on and pressing the gas pedal and Etc... Etc.. like a ritual with exact timing

:confused::confused::confused::confused:
 

·
Registered
Joined
·
1,165 Posts
There are many topics with the same title, but can anyone tell me what to do after unpluging and reconecting the Negative battery wires. How many KM's Miles do i have to drive and at what speed?

in the nissan forum they describe it as

leting the switch on and pressing the gas pedal and Etc... Etc.. like a ritual with exact timing

:confused::confused::confused::confused:
I cant remember how long it takes. But it shouldn’t take that long. It just need to see how your sensors are operations. When i do mine, it didn’t take that long. I can drive around town and it usually learns it by then...

If you are trying to see if a cel comes back. drive around for like a mile then shut off you car.. repet three times to five times and see what happens... Mines usually comes back by then...

Hope this helps....
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #3 ·
yes but i feel way better when you drive about 30 - 50 kms after reseting the ECU rather than of my daily driving about 10 -12kms from work and back after resting. Is there a minimum Kms you have to drive to set all the values to the ECU??
 

·
Registered
Joined
·
19 Posts
I drove my 97 X3 for about 100mi/161Km before getting the emissions test done.

The emissions test here in Georgia requires that the computer pass a "readiness" test before any emissions data is pulled. This checks and makes sure that the computer has relearned everything.

I do not believe that there is a minimum speed. I drove most of the 100mi from 0-65mph over a 6 day period.

Hope this helps.

Dean
 

·
Registered
Joined
·
1,787 Posts
I drove my 97 X3 for about 100mi/161Km before getting the emissions test done.

The emissions test here in Georgia requires that the computer pass a "readiness" test before any emissions data is pulled. This checks and makes sure that the computer has relearned everything.

I do not believe that there is a minimum speed. I drove most of the 100mi from 0-65mph over a 6 day period.

Hope this helps.

Dean
hat sounds a bit right. I had to wait 150 miles when I revived the 03 Tiburon back from the dead before I could even take the test here in California. But it is freeway driving hey are looking for. High speed flux. go 65 for a few mins. take it to 80...down to 70 then to 90 then repeat.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #7 ·
Yeah , I felt that too when i drove my car over 70 KmPH for a few mins te car seems to act very diffrently and has more power , unfortunately i couldn't in the weekdays.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #8 ·
I feel that just after reconnecting the Battery wire it is avery good practice to let the car idle for a about 1 min before driving, I felt a difference
 

·
Registered
Joined
·
183 Posts
I didn't think it takes that long at all. All the car does when you reset the ECU is advance the timing more and more until it gets detonation then backs it off a bit.
 
1 - 9 of 9 Posts
Top