Hyundai Forum: Hyundai Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I'm writing here because I"ve brought my car to a Hyundai dealer over 8 times, yes 8 times for the same issue. I finally have some bigshot coming in the 25th to take a look at it, but in the meantime I wanted to see if this is a similar issue that people around these boards know the answer to.

There are many symptoms that happen. My car is a 2004 Hyundai Tiburon, 5-speed, 4 cylinder. Thanks a head of time!

1) Every time I start the car, all my memory, including the clock and radio reset.

2) My dome lights won't turn on when I open the door, or if they do it's sporatic, they will either come on or off. If they're off, doing something like pressing the brakes will turn them on, it's always like they're trying to turn on.

3) As I'm driving, if I use my blinkers, roll either window up or down, turn on or off my brights, the car stereo will momentarily turn off and disconnect, and the headlights dim down really quick, as thought the power is being taken away from them.

4) During the summer when I used my AC the car would almost die, and for a split second it will halt and jolt, and the check engine will come on during that period, as though the key is turned on the accessory setting.

5) After being in the shop it always works for about a week, I think this is due to removing the battery (the reason I also know this is I replaced a headlight and disconnected the battery and all my symptoms have been gone for 4 days now).


Here's what the shop has done.

-Replaced battery twice.
-Replaced the alternator.
-Replaced some accessory control module (not exactly sure).
-Replaced a battery cable of some sort, it had to be ordered.
-Retraced and tightened all wires and grounds.
-Replaced a main engine fuse.


I would love to have some ideas thrown at them, or say eff em and do it myself, I wrote a letter to Corporate Hyundai and that's why I'm getting someone to fly in to look at it, since they can't handle it.
 

·
Registered
Joined
·
7,118 Posts
I think they need to replace the entire harness. They don't want to do that because its a PITA.

BTW mine does the dome light thing. I just turned it off. If I ever get around to figuring out what its problem is I will let you know.
 

·
Registered
Joined
·
3,944 Posts
this is a ground issue. I would check the interior wiring harness ground connection- probably somewhere in your footwell near the fusebox. check voltage drop from the ground wire to the battery. retightening the grounds won't do any good if they've accumulated hidden corrosion or paint is between the connections... but you're describing an open ground situation perfectly, I can't believe the dealership can't fix it...wish I could see it I love that stuff :)
 

·
Registered
Joined
·
1,121 Posts
The body control module takes care of just about everything on the car SAVE for engine management.

A very common problem with the Tiburon - however if replaced already (you note an Accessory Module as being replaced) I am surprised if the issues are persisting.

Please advise after the vehicle is repaired - I am surprised.

Regarding a note that the harness is a PITA to replace - it is, but keep in mind that the dealer is being paid to replace it, and makes a small profit on the parts as well. The only thing is - if the problem is mis-diagnosed and the harness does not solve the problem - the dealer eats the repair.

Let us know!
 
1 - 4 of 4 Posts
Top