Hyundai Forum: Hyundai Performance Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
When I press on the throttle to make sure the engine is running smoothly and sound when in park the engine seems to kick for a split second when i first press on the throttle to give the engine gas . the engine literally jumps, then stop and runs normal
 

·
Registered
Joined
·
464 Posts
The front and/or rear roll stops (a.k.a. engine mounts) are shot. Remove them and fill them with 3M fast drying window-weld, silicone, or some similar substance, and reinstall.

Or replace with new.

Filled mounts will transfer some NVH to the car, but compared to how much my car rattled and shook when the engine was riding on 1 failed and 1 failing mount, with silicone filled mounts it is WAY smoother.
 

·
Registered
Joined
·
686 Posts
no need to pull the engine, its just the mounts, get under your car, have a jack support your engine and unbolt the mount
 

·
Registered
Joined
·
8 Posts
My engine does a smilar clunking sound when accelerating and decelerating - most likely the engine mounts. I tried to visually inspect them, but its hard to determine if they're torn because they have some sort of rubber flap covering them. How possible is it for them to look fine, but shot once I remove them? I guess what I am asking is, could the sound be coming from something else?
 

·
Registered
Joined
·
686 Posts
thats really the only thing that would make that clunk sound
 

·
Premium Member
Joined
·
1,447 Posts
that clunk is the intake manifold bouncing off the firewall normally. i also had a clunk sound when my trans mount went bad. I dont know how long you guys have had your cars, but this is covered under hyundais warranty
 
1 - 8 of 8 Posts
Top