Hyundai Forum: Hyundai Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Ok, this morning I was driving to work, stopped for a coffee, all the norm. Car had a tiny hesitation taking off in 1st gear once, might of been cause it was cold, after that ran fine. Got on the highway, driving along all is good, go to give it a little more gas cause of a hill and next thing you know I have no power. When I pressed the gas it sounded like the engine had compression cause it would get that deep "bohhhhhhhh" sound when I pressed the gas a couple times. Im not sure if its the timing belt cause it still had compression after it cut out, unless it would still do that. It might of been an electrical problem? Cause i remember my radio cut out and back very quickly when it happened. I didnt really have time to check it over, but Im thinking its either to do with the fuel pump or ignition coils, any ideas?
 

·
Registered
Joined
·
147 Posts
Loose Battery cablesor/cable.. check ur battery
 

·
Registered
Joined
·
686 Posts
sounds like a fuel problem to me
is your check engine light on?
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
Ya my car tripped an evap leak code a few months back and it keeps coming back here and there, mechanic told me to wait cause it wasnt affecting anything. Im thinking I should of got him to locate it back then heh.
 

·
Registered
Joined
·
686 Posts
isnt evap leak like a loose gas cap? or the seal on gas cap is bad and need a new one
 
1 - 5 of 5 Posts
Top