Hyundai Forum: Hyundai Performance Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
3,276 Posts
Discussion Starter · #1 ·
I finished installing my water/meth injection kit today (devils own). Its the basic kit with a nice pressure switch instead of the progressive. I set it to start spraying at 15psi (nervous lol). I just went to the other town and back and this is my experience so far. In the reseviour i used one bottle of heet which is like 99% meth and filled the rest up with distilled water. Its about a gallon resevoir, not sure what that makes the mix. So I took it out and was afraid to get on it for awhile, finally I said o well and hit it. Seat of the pants felt a little better than usual, most noticable after 15psi of course. So I did a few pulls back to back and pulled over to check the intake manifold, felt noticably cooler than usually (typically its too hot to touch almost). I dropped the pressure switch down to activate at 12-13psi (Im running 21psi). Did another pull, something went wrong.... The nozzle blew out! Took it apart put the washer on the INSIDE of the coupling (silly mistake) and off I went. Did several more pulls on the way back each one feeling pretty good. Leaving the toll plaza I got on and poof went a chargepipe. That hasnt happened in ALONG time.... I'll use this thread to post as i go on about this and i will be getting back on the dyno to do some tuning since i am a little bit richer than i was. I also plan to swap to a larger nozzle, im currently using an m2 which is pretty small. My mix is slowly going to be more and more meth , I may end up running 100% meth or very close to it. When I swap to a larger nozzle i hope it dont bog like i hear happens to some people. From what I read it shouldnt be a problem though since my boost builds really fast. I'll post back later, I gotta go reset this charge pipe in place with a fresh bit of silicone.
 

·
Registered
Joined
·
3,276 Posts
Discussion Starter · #5 ·
I'll try to get pics of the kit installed later, we're going to fun world today. The pipe that blew off is the coupling where its attached to the mass air flow sensor. The maf sensor is smooth and so is the coupling so the only way i could make it stick was using silicone in between the two. Held for along time but finally blew off, o well. Im using some heavy duty clamps. If i get home before its dark today i'll swap the larger for a nozzle one and do some test driving.
 

·
Registered
Joined
·
687 Posts
I had that problem w/an intercooler once...

What DSM'ers do a lot is take some JB weld and roll it into a thin string and then affix it at the end of the pipe. That way, your clamp has something to hold the silicone coupling to. JB weld does work on plastic, no?

Howie~
 

·
Registered
Joined
·
3,276 Posts
Discussion Starter · #7 ·
I never tried jb weld, silicone has always worked well. Im going to out and swap the nozzle and mess around as soon as the rain lets up here...
 

·
Registered
Joined
·
3,276 Posts
Discussion Starter · #9 ·
Turned the pressure switch down to 10psi today. Blew off the same pipe so i bought some throttle body cleaner to get all the oil out (everytime i blow a charge pipe the turbo blows oil). I got some epoxy mix and used it to hold the pipes togother. Seems to of worked perfect so far. I added 2 more bottles of heet to my already existent mix of 1 bottle of heet and the rest distilled water. Running top notch so i'll switch to the larger nozzle hopefully tommorow if i have time. Intake manifold is cooler to the touch, with the larger nozzle should be cool to the touch.
 

·
Registered
Joined
·
3,276 Posts
Discussion Starter · #10 ·
Well i swapped to an m5 nozzle 2 days ago. It doesnt bog and its kicking in at 10psi. The car feels much more powerful and its loving it! Im going to get this stuff called boost juice its a 50/50 mix of water meth so i will have a perfect mix. So far I love it!
 

·
Registered
Joined
·
845 Posts
Cool. I might have to look into that in the future. What brand is your kit?
 

·
Registered
Joined
·
3,276 Posts
Discussion Starter · #12 ·
Its the Devils own injection kit. Just the basic kit though, couldnt afford a progressive lol.
 

·
Registered
Joined
·
3,276 Posts
Discussion Starter · #14 ·
Methanol. I had to make a change to the pressure sensor and allow it to kick in about 15psi instead of 10. Reason being first gear was on the verge of rich breaking up before i installed the kit and with the injection in first when it hits 10psi it bogged real bad. Shame, its the only gear that did it but I couldnt tune out first gear unfortunantly.
 

·
Registered
Joined
·
3,276 Posts
Discussion Starter · #16 ·
See my post here in the FI section about added 2 quarts of oil to my charge pipes.... My turbo blew so the cars down again. I dont even know what turbo will fit with this lousy scoupe manifold. Im trying to find a t2 to t3 adapter, know where i can find one?
 

·
Registered
Joined
·
3,276 Posts
Discussion Starter · #18 ·
Sorry, no the turbo blew because i was running it with the the wastegate line pulled for so long lol
 

·
Registered
Joined
·
1,186 Posts
Meth likes to react with the oxide coating on aluminium surface(protects the aluminium).

Corrosive cycle.
Part 1: Methonal reacts with oxidized aluminium by converting the oxide layer into a salt, this salt dissolves in methanol, this leaves an pure aluminium surface.

Part2 the pure aluminium surface almost instantaneously reats as soon as it is expose to oxygen (so when the meth and aluminium salt drips away the lovely atmosphere provides some oxygen), creating a layer of protective oxidized aluminium.

Part 3. Go back to part one

So your manifold and other aluminium parts are being slowly turned in salt.
 

·
Registered
Joined
·
3,276 Posts
Discussion Starter · #20 ·
That would worry me if :
1. I was running tons of methanol
2. I've ever heard of it causing a problem on someone else's car. Their are ALOT of water/meth injected srt-4's and wrx's around my area of town. Alot of them have been using the system for years.
 
1 - 20 of 23 Posts
Top