Hyundai Forum: Hyundai Performance Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
176 Posts
Discussion Starter #1
When im at a stop it levels out fine but when i start goin it like decreases.. is it supossed to do this?
ill give it some what alot of gas and itll drop alot.. is it my fuel pump?
any info will help
 

·
Registered
Joined
·
3,276 Posts
Where is the fuel gauge installed, this can affect the reading.....
 

·
Registered
Joined
·
176 Posts
Discussion Starter #3
its the stock
in the cluster
 

·
Registered
Joined
·
3,276 Posts
Oh okay lol I was thinking fuel pressure gauge... Sounds like something is wrong with the float.... Have you switched fuel pumps or anything? After installing a walbro in my car if im below 1/2 tank it drops to empty at high speeds lol
 

·
Registered
Joined
·
176 Posts
Discussion Starter #5
as far as i know its stock and never switched.. and i was thinkin of ordering the walbro.. isnt it the 155lph? and would it require any like bigger things
injectors etc.?
im just makin sure my gauge doin that shows that nothing is wrong.. i think somethings suckin up the gas.. im tryin to find the fuel filter in this car too to switch out.
 

·
Registered
Joined
·
3,276 Posts
Not sure about your car but my fuel filter is on the firewall. Late model accents have a fuel filter right beside the fuel tank and most of our cars have another filter located on the fuel pump itself. The walbro is a 190 or can get a 255. Just sounds like the float is sticking for some reason....
 

·
Registered
Joined
·
176 Posts
Discussion Starter #7
I did put my own orange led's in the cluster instead of the **** white ones.. maybe i messed it a lil while popin the needle off?
 

·
Registered
Joined
·
3,276 Posts
That is possible....
 

·
Registered
Joined
·
466 Posts
Why did you take the needles off to change the colour of the bulbs? Did you try just taking the bulbs out of the back?

My guess is that is your problem. If you take it to a dealer they will probably fix it for you for free. When I was looking at making some gauge faces I broke the fuel gauge needle off and they replaced it for me under warranty.
"I dont know how it happened but the needle wasnt moving for a while then i just broke off one afternoon... I swear..."
 

·
Registered
Joined
·
176 Posts
Discussion Starter #10
oh sorry i meant i took the cluster out when changin the bulbs AND addin red neeles instead of the white ones.. lol my bad:surprised:
 

·
Registered
Joined
·
466 Posts
I think the way i was going to fix mine was to leave the needle for fuel off until i fill the car up next. Fill it completely and then wait 5 mins while driving. When you get home, put the needle on just above the full line. This should get it fairly close. The temp guage is an easy one. wait till the cars warm then put the needle between the two magnets.
 

·
Registered
Joined
·
176 Posts
Discussion Starter #12
yea mine was ok.. i filled it andit leveld out great i had it good the first time haha
and my temp gauge was always jumpin al over so i gota autometer.
 
1 - 12 of 12 Posts
Top