Hyundai Forum: Hyundai Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,714 Posts
Discussion Starter #1
Hey, I was driving around alot lately and noticed that after I hit 60MPH or more...my handling becomes very loose and not as stiff as it used to...I havent put in any air in my tires for a while..and I havent driven the car all summer, since I was away...what do you guys think the problem is??thanks...
 

·
Registered
Joined
·
646 Posts
It could be your shocks. Mine started deteriorating badly after 75000kms. It felt like crap, but was much more obvious at higher speeds. New shocks cleaned up that problem pronto!
Other than that, I don't know what it could be. Could your swaybar worked itself loose? I doubt it, but don't know what else to suggest?
 

·
Registered
Joined
·
2,714 Posts
Discussion Starter #3
Oh man....I just got these KYB struts not too long ago....and I only have 16000 miles on my car....but I did hit some big potholes lately...and one big ass one a couple weeks ago that made my car fly or at least jump high...do you think anything else could be wrong from hitting a big pothole or man hole??would that make a swaybar loose??
 

·
Registered
Joined
·
67 Posts
Check your tire pressures, inspect your wheels and suspension. Hitting potholes may have bent a rim or suspension part or knocked the car badly out of alignment.
 

·
Registered
Joined
·
2,714 Posts
Discussion Starter #5
Yeah..thats what I was thinking...hopefully its only my tire pressure...thanks
 

·
Registered
Joined
·
646 Posts
Oh, you hit something hard? Wow, then it can be anything. I would check for anything bent.
 
1 - 6 of 6 Posts
Top