Hyundai Forum: Hyundai Performance Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
Hello all,

I have a 98 Accent, not sure what version, I think a CC but that could be wrong. Anyways, I was thinking about doing some mods and disconnected the door bell, and got to thinking about adding some different coloed bulbs to the cluster gauges. Well in looking to see what it would take, I unscrewd the cluster from its mount and pulled it toward me to look behind. So now I know where the bulbs rest.

Heres the problem.... My speedometer does not work now. I have it aligned properly and pushed into its socket where I think the end of the cable is and screwed it back on. Well discovering on my way to work that I don't know how fast i was going:eek:. Now I'm wondering what I did wrong to not have it working. Does anyone know how to get this set up again?:D

Plus has anyone made any mods to there gauges or replaced the gauges with any aftermarket cluster? If so, where do you find them??? And or can clusters be swapped out with another style? List any websites for aftermarket gauges that will fit a 98 Accent.

Please let me know, I'd like to get it fix this weekend. My Chiltons manual is very limited on info and pics on how to fix this.

Thanks!!
 

·
Registered
Joined
·
1 Posts
Sorry I can't help you with your speedo malfunction, it sounds like you'll have to check that the inner cable is correctly seated at both ends. As far as alternative gauges are concerned, if you have the standard (non-tacho) X3 cluster, a popular option is to get (maybe from Ebay) the GX cluster with the tacho. I found Untitled Document
(click on the 'Untitled Document' will take you to a Geocities.com article) very helpful, but I found there were a few errors in the plug pinouts (which you should be able to work-out) and the ECU wire colours for the tacho signal were reversed. With a little care it can be done.

If you find an after-market cluster I would be interested to hear about it.
 
1 - 3 of 3 Posts
Top