Hyundai Forum: Hyundai Performance Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
9,188 Posts
Discussion Starter · #1 ·
So the accent engine I swapped in runs OK, until you give it more than half throttle at higher than 4k RPM a MASSIVE oil cloud exits the tailpipe. It's a MASSIVE cloud, takes out cars behind me.

What the hell could it be? If you keep the revs low, it doesn't happen. A friend said aside from the obvious (rings/valves) it could also be a stuck open PCV that's allowing oil from the rocker cover (at higher pressures) directly into the motor. Im gonna try to remove the PCV hose and plug it, drive it around again.

THen im gonna do a wet/dry compression test... if the problem is in the head i'll put the old head on... but if it is the block I SHALL SNAP!!!!!!!!!:mad:

Any other ideas?
 

·
Registered
Joined
·
715 Posts
Valve seals...
 

·
Registered
Joined
·
9,188 Posts
Discussion Starter · #4 · (Edited)
OK this is the stupidest thing i've ever done... I checked the oil today and... there's totally 8 quarts in there.

I'm gonna drain some and have a drive.

I was wondering what that sloshing sound was...
 

·
Registered
Joined
·
3,497 Posts
do a complete drain/fill with filter and drive the car a while (at least a week) and see if it continues to burn oil. If it does, it could be a number of things from rings to valve seals.
 

·
Registered
Joined
·
9,188 Posts
Discussion Starter · #7 ·
There is absolutely no oil burning whatsoever!!!! I can't believe I did something that stupid.... at least the excess oil pressure filled up the HLA's, the engine runs silent!
 
1 - 7 of 7 Posts
Top