Hyundai Forum: Hyundai Performance Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
176 Posts
Discussion Starter #1
so i decided to do alil tune up and i just tightend some bolts and made sure some wires were all tight and such.. but i start it up
and im gettin high and low revs
constantly.. i mean i didnt even mess with anything tps and such
just mostly cleand up the bay. :cry: itll rev high then low over and over wont quit
 

·
Registered
Joined
·
45 Posts
Do these engines have an IAC? Sounds like a problem I've always refered to as "Hunting" The engine is "hunting" for it's ideal RPM at idle. Is it doing it when you drive? Or does it drive normal? In the Mitsu's it's usually either the BISS or the IAC Motor. I don't know if your engine has the same thing or not...
 

·
Registered
Joined
·
29 Posts
yeah, my 92 excel is doing the same thing. It searches or HUNTS for a decent ****ing idle. It has been pissing me off because it sounds like it is breathing. I hooked up a scanner to it, and it reads three fault codes:
1. MAF sensor problem
2. Intake air tempearture sensor problem
3. Barometer(metric?) postion...something something. I cannot remember. But nothing reads into the IAC sensor. That **** is $216 from the DEALER!!! any ideas? I have the G467** Engine or 4g15
 

·
Registered
Joined
·
176 Posts
Discussion Starter #6
I cleaned up my bay with some basic degreaser.. i made sure to stay clear of wires and shiz.. it was just wierd.. startin it up and yea.. i have spare maf;s layin around so i switched those.. nothing worked
.. then tried the TPS.. switched em.. nothing.:surprised:
 

·
Registered
Joined
·
176 Posts
Discussion Starter #8
and this will do what
 
1 - 8 of 8 Posts
Top