Hyundai Forum: Hyundai Performance Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
HELP! I think I royally screwed myself with my 2000 Elantra station wagon. I was in the middle of a stereo swap out, when a wire came loose and touched something. I'm not sure what it touched, but it was a yellow wire. After I put everything in, the following no longer worked: A/C, fan, heater, windshield wipers (front and back), radio, head lights, and power windows. I checked all of the fuses both underneath the steering wheel and in the engine compartment. Everything looks fine. I think something shorted and I do not know how to fix it.

-jef
 

·
Registered
Joined
·
60 Posts
Take a look at your owners manual and find out which fuses belong to the ones that dont work. Double Check your fuses, all of them, take them out one by one and make sure that they are not toast.

If you are positive that its not fuses youll have to go into the dash and check the wiring. You might want to check each problem system wire with a test light.

I dont know if Ive been any help, but good luck... let us know how it turned out.

Nilo K

:)
 

·
Registered
Joined
·
86 Posts
Make sure to test your fuses with an Ohm-meter. Sometimes fuses will open and they still look closed.

Do you have the iginition switch in ACC or ON. I know it sounds stupid but its happened before.

You might have also grounded the wire, but there is enough resistance in the return that the fuse won't blow, but your devices won't work either. Check the wiring.

Jenkins
 
1 - 3 of 3 Posts
Top