Hyundai Forum: Hyundai Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
Hey guys I need your help. I have 2001 hyundai elantra and the car has been running really bad. When I put my foot on the gas the car stutters and jumps alot, I basically have to take my foot off the gas a slowing speed up. Does anyone know what the problem is? It also makes a loud loud squeaking noise when it starts, but I guessing that just a belt, but maybe the two are related. Please help
 

·
Registered
Joined
·
2,318 Posts
The squeaky noise is most likely the alternator belt. Make sure it is in good condition and that it is tight.

The hesitation under accleration could be spark plugs/wires or your throttle position sensor. Good luck.
 

·
Registered
Joined
·
687 Posts
There needs to be a little more information...

Any Check Engine Lights on? How many miles on the car? Have you checked your Mass Airflow Sensor?

Howie~
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #4 ·
Thanks for the advice Whiplash_89 I was thinking it might be spark plugs, but well see. As far as more info: the check engine light is on, but thats been on since I put my headers because they didnt have a spot for the second sensor. The car has about 65,000 miles on it and last I have not check my mass airflow sensor. I dont know to much mechanically so havent really check much. I was hoping you guys could point me in a direction and I could go from there.

I appreciate the help guys.

Thanks
 
1 - 5 of 5 Posts
Top