Hyundai Forum: Hyundai Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2,809 Posts
Discussion Starter #1
So I get in line to wait at the freeway onramp and while i'm idling my engine starts knocking. LOUD! I heard it over the radio. And the engine starts jumping on its mounts. So I rev it up and let out the clutch to start moving and it almost dies. So I keep it revved up and "milk" the clutch overly slowly. It seems to be ok if I keep it revved too high and use(abuse, whatever) the clutch alot.

So I take the long way home to test it and when i punch the gas, the pedal comes back but the engine stays revved for 4-5 seconds, then begins to drop slowly. When i got home I checked the cable to make sure it slides smoothly and it does. Also, the spring at the end of the cable works if I move it far in either direction so I'm starting to think its an electrical issue and not mechanical. The cable does have about 1/4 in. slack though.

So I kept repeating the behavior, making it reoccur, (basic troubleshooting step), and then i let it idle for a sec, and whenever the fan kicks on, the engine hiccups and dies!

This blows, any ideas? I can still drive it if I'm hard on it, but I'd rather fix it. I know little about engines other than basic concepts shared in common with small engines (lawnmower, etc.) My dad says he thinks it's called the THC valve (too much mary-jane for him i suppose).

So now it stays revving sometimes and dies if i let it idle for more than about 10 sec. WTF! Can anyone help?

[Edited by busy_squirrel on Oct 25, 2005 6:16 PM]
 

·
Registered
Joined
·
2,809 Posts
Discussion Starter #5
Problem solved! 2nd resonator fell off after off-roading loosened it awhile back, so air meter was not reading correct air flow, so air/fuel was off.
 
1 - 5 of 5 Posts
Top