Hyundai Forum: Hyundai Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
The engine on my Tib makes a "tick-tick-tick" noise that speeds up when I rev the engine. I'm guessing its the lifters (or HLA's... or whatever you wanna call them) In the past things would get better after an oil change or if I added a bit of oil. For my last oil change I ran some flush through, but I'm still getting the ticking...

I've heard of the HLA's "collapsing" and needing replacement... are there any symptoms that would point to this (besides the ticking)? I have rough idle sometimes and the ECU didn't like my CAI and I ended up taking it out, but those are the only problems I've been having...


<hr noshade width=60% size=1 align=left>
 

·
Registered
Joined
·
1,170 Posts
Sometimes the alternator can make a ticking noise. Check that out too.


<hr width=60% noshade size=1 align=left><img src="http://publish.hometown.aol.com/jrh382/myhomepage/elantraborbets1.jpg?mtbrand=AOL_US" border=0>
2000 Hyundai Elantra GLS (Photochop)
-PIAA 1100 series driving lights
-PIAA Plasma Headlights
-10" Pioneer sub powered by Kenwood 600 watt amp
 

·
Registered
Joined
·
1,893 Posts
I would do the motor flush for 2 to 3 oil changes (with filter), and do it right at 3000 miles. If that still doesn't solve it, one of your HLA's might have gone bad.


<hr width=60% noshade size=1 align=left>quote from 4DoorGL: "Told you. Random is cool as hell in person, even if he is a dick on the net <img src=/images/forums/snitz/wink.gif width=15 height=15 border=0> (j/k)"

Leave it to Random to Needlessly complicate things.
 

·
Registered
Joined
·
324 Posts
I have the same problem with the noise. But I don't hear comming from the motor, it's somewhere else. I thought they were from the injector? Are they?<img src=/images/forums/snitz/guns.gif width=33 height=16 border=0><img src=/images/forums/snitz/cry.gif width=16 height=16 border=0><img src=/images/forums/snitz/cry.gif width=16 height=16 border=0>


<hr width=60% noshade size=1 align=left>'01 Cardinal Red Tiburon
17" Nakayama Shumacher Racing Wheels
AOS CAI, Magnecor Wires
Zex Hyperformance Plugs
Sony Xplode system
MTX Subwoofers
Shark Racing Strut bars
Cat-back exhaust, yellow front and back grill
Flame graphics, Indiglo Gauges
 

·
Registered
Joined
·
60 Posts
according to the boys that service my accent at FOCUS HYUNDAI, the ticking noise comes from the purge valve for the fuel system...it only happens to my accent when its cold..which is often here..unfortunely, the p.v is located by the front drivers side fender so the noise is amplified...sounds like a typewriter...I guess its a quirk of driving a Hyundai.<img src=/images/forums/snitz/guns.gif width=33 height=16 border=0>


<hr width=60% noshade size=1 align=left>
 
1 - 5 of 5 Posts
Top