Hyundai Forum: Hyundai Performance Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,132 Posts
Discussion Starter #1
hey
my ...lifters/valves/ cam clicks, like a clock, tickTICKtickTICK as the car idles, and of course speeds up as the car accelerates. i listened to it, and it seems to be comming from the valve cover/near there. its not the belts im sure. i heard this could be caused by dirt/other crap in there? so, what could it be, or how could i fix it? It hasn't always done this so i kno it might not just be normal, but it does have 63K on it. it has done it before, and then it'd stop, now it seems to be doing it all the time.

Accent GSi (98, black)
Naxos muffler
Clear side markers
Custom front grills

Custom CAI soon...
 

·
Registered
Joined
·
1,170 Posts
SuperElantra had a problem like that in his 1999 Elantra. However, it may not be that because clicking in the engine can be among several things. Could be engine knocking, for one. My old Toyota Corolla had a bad clicking noise in it if you put cheap gas in the car. I had to consistently switch to ultimate and the noise would go away. So, next time you fill up, try a higher octane. If you are using 87, try 93. If it stops, theres your problem EASILY fixed. If it don't then you have a serious problem on your hands and you better bring it in to get looked at.

2000 Black Hyundai Elantra GLS
<img src="http://canineanalrape.homestead.com/files/wavy_usa_flag.gif" border=0>
God Bless America
 

·
Registered
Joined
·
1,893 Posts
If the higher octane gas does not fix it. Try running "motor flush" through the engine at your next oil change. One of your Hydraulic Lash Adjusters might be gummed up and the motor flush should clear that out.

Leave it to Random to Needlessly complicate things.
 

·
Registered
Joined
·
232 Posts
ohh ohhh i know i know..........ok at least on 2k1 tiburons there is a small connector that comes disconnected and starts tapping on something in the engine bay.....i had the same thing dealer fixed in a few hours once they figured out what it was :)

that could also be it?
 

·
Registered
Joined
·
21,319 Posts
<BLOCKQUOTE id=quote><font size=1 face="Verdana, Arial, Helvetica" id=quote>quote:<hr height=1 noshade id=quote>
If the higher octane gas does not fix it. Try running "motor flush" through the engine at your next oil change. One of your Hydraulic Lash Adjusters might be gummed up and the motor flush should clear that out.
<hr height=1 noshade id=quote></BLOCKQUOTE id=quote></font id=quote><font face="Verdana, Arial, Helvetica" size=1 id=quote>

What I told you in the other post.

Please only post once for each topic.

Thankyou

<img src="http://www.coreyandjayshow.com/pee.gif" border=0><img src="http://www.hyundaiperformance.com/upload/binladen.jpg" border=0>
 

·
Registered
Joined
·
1,132 Posts
Discussion Starter #6
sorry <img src=icon_smile_blush.gif border=0 align=middle> not everybody reads both accent boards and mainteance boards tho! just tryin to get good info is all <img src=icon_smile_wink.gif border=0 align=middle>

Accent GSi (98, black)
Naxos muffler
Clear side markers
Custom front grills

Custom CAI soon...
 

·
Registered
Joined
·
21,319 Posts
No prob<img src=icon_smile_big.gif border=0 align=middle>

This was the better board to ask the question in though<img src=icon_smile_big.gif border=0 align=middle>

<img src="http://www.coreyandjayshow.com/pee.gif" border=0><img src="http://www.hyundaiperformance.com/upload/binladen.jpg" border=0>
 

·
Banned
Joined
·
9,547 Posts
Originally posted by 98 Exceller
[body]
Does your noise sound like this? I posted info on this earlier - http://www.hyundaiperformance.com/forums/topic.php?t=54764
[/body]
holy crap, do you rwalize that this post is 3 years old?
 

·
Banned
Joined
·
9,547 Posts
Originally posted by KdMkIdd00
[body]
engine flush and synthetic oil made my "ticking" go away sounds like the same thing
[/body]
most of the time with hydrolic lifters the oil port gets clogged and the oil is not able to make the cushion between the lifter and the rocker. using an oil flush will usually unblock the passeage and fix the problem
 

·
Registered
Joined
·
21 Posts
My experience with hydraulic lifters (dodge small block), if they don't pump up, the engine runs like crap as they collapse and provide zero or little valve lift. I noticed the other day when I was doing some investigating about my noise, was that the rattle actually starts about 3 seconds after start up when the oil should be pumping up those lifters. The rattle seems to be there even after it warms up but not near as noticeable, I actually had to right over the valve cover and reving up the motor to hear it. I sure am wondering about the HLA's:puzzled:
 
1 - 13 of 13 Posts
Top