Hyundai Forum: Hyundai Performance Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi everyone,

I've been forever browsing the Accent and Maintenance forums for possible fixes to my 2000 LC (auto). There is no CEL showing up.

Here's the story so far:

- car is stock have taken it in for all scheduled services
- MAF was replaced 1.5 yrs ago
- Pulse Generators replaced this year
- 300km per tank on 100% city driving
- mileage 98,000km
- had belts, spark plugs, air filter changed recently
- fuel consumption only became really bad this year

So far I have checked:

- tire pressure, spark plugs, sensor connections
- reset ECU


I'm trying to narrow it down and so far I'm thinking:

1. O2 sensor is faulty
2. MAF sensor is dirty

Can anyone else suggest a possible source?

I will be taking it in for service next week.
 

·
Registered
Joined
·
1,059 Posts
I hope you are not using Ethanol blended fuels. The will screw withyour O2 sensor and could cause poor fuel mileage. It is happening a lot in Quebec since they swithed to at least a 10% blend.
 

·
Registered
Joined
·
386 Posts
That will probably be the way you drive, type of driving conditions, how you beat or rev the engine
and The weather, also tire pressure and brake drag. or wheel bearing(will make noise)

The only thing would be AIRFILTER, and some injector cleaning.
If it's the fuel filter, the CEL will come on, because the O2 sensor will see it.
if the O2 sensor goes, the CEL will come on.
check you CEL light.
anything wrong the cel will probably come on except leaks
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
Thanks for the suggestions.

I usually gas up at ESSO or PetroCanada

I will look at the air filter again

could the MAF possibly have gotten covered with dust/dirt that it's reading is thrown off and thus affecting gas consumption?
 

·
Registered
Joined
·
48 Posts
iam going through the same thing with my 2001 accent only difference im getting 240 kms to the tank maybe between the two of use we can figure out this mistery.
I only have 62000 kms on my car granted when i start it up i can smell gas from the exhaust and its black in the pipe ?:puzzled:
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
- Update -

Had the car taken to the dealer to get scanned (remember no CEL) and a de-carbonizing done.

- Computer was scanned, no codes showed up
- De-carb was done over night at dealers

We filled it up took it for a spin home 50/50 highway/city for about 50km.
Filled the tank back up to see how much gas we used up = 4.7L :D

So just under 10km per 100km ~ 30 mpg (in theory)

So hopefully since the LC is a 44L tank I "should" get around 440km city driving *cross fingers*

Remember there is a diff between US Gallons and Cdn Gallons

I used this as a guide: http://oee.nrcan.gc.ca/transportation/tools/fuel-consumption-guide/pdf/fuel-consumption-guide-2005.pdf


Will keep you posted as well sweetride

Hopefully this was the main problem. :??:

*crosses fingers*

[Edited by diesel204 on Oct 26, 2005 7:45 PM]
 

·
Registered
Joined
·
48 Posts
Thanks,well i finnaly got a code,the dealer said it was my mass senser well changed it,airfilter,sprayed some cleaner in her and it picked it up to about 250 kms,still crappy for the heck of it i pulled my muffler it seemed to get better throttle response revs quiker from about 3500 rpms and up not sure of gas mileage yet
 

·
Registered
Joined
·
191 Posts
Originally posted by diesel204
[body]
- Update -

Had the car taken to the dealer to get scanned (remember no CEL) and a de-carbonizing done.

- Computer was scanned, no codes showed up
- De-carb was done over night at dealers

We filled it up took it for a spin home 50/50 highway/city for about 50km.
Filled the tank back up to see how much gas we used up = 4.7L :D

So just under 10km per 100km ~ 30 mpg (in theory)

So hopefully since the LC is a 44L tank I "should" get around 440km city driving *cross fingers*

Remember there is a diff between US Gallons and Cdn Gallons

I used this as a guide: http://oee.nrcan.gc.ca/transportation/tools/fuel-consumption-guide/pdf/fuel-consumption-guide-2005.pdf


Will keep you posted as well sweetride

Hopefully this was the main problem. :??:

*crosses fingers*

[Edited by diesel204 on Oct 26, 2005 7:45 PM]
[/body]
thatr is 9.4L/100km so this equals 24.7 MPG which is still pretty low for your car which should be averaging 28-30MPG
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
UPDATE:

No change in gas consumption still 9.4 - 10L/100km (24mpg) city driving

No check engine lights

I'm thinking it could be an O2 sensor that's on the brink of failing. Those things are
about $90CAD each!

+ All plugs are new
+ All belts are new
+ MAF replaced last year
+ Tires properly inflated

Anyone else suggest things that I could check?

Thanks for all the help so far
 

·
Registered
Joined
·
5 Posts
For fuel I had tried on highway and city
shell>esso>PetroCanada
so shell can drive more then petro but smell better then shell
 

·
Registered
Joined
·
23 Posts
I have had a similar problem with my 2000 Accent GL. I used to get exactly 320 miles per full tank of gasoline. I have a little over 110,000 miles on my car and now I'm lucky if I can sqeeze out 220 miles per full tank. I also burn about 1 quart of oil every 1000 miles. I take excellent care of my car and get my oil changed every 3k miles. I took it to the dealership right before i hit 100k and they told me it was the plugs. I change the plugs and had the same problem. Then they told me it was the wires so I had them change the wires. Then they found something wrong with the CAT so they claimed to have fixed that. Anyway, the CEL is still on and it feels like it's misfiring. My warranty is up and it still gets horrible mileage and burns oil. The dealership told me it was just old age. I don't like the dealership. I've been using synthetic oil now which seems to be a little better. I'm taking it somewhere else tomorrow because I think it's an injector or the MAF which I had to change at around 65,000 miles.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #14
Sorry to revive an old post but had to post some follow up results.

Apart from my Fuel Gauge being inaccurate...I have noticed a few more things:

Recent fillup 87 octane:

25.9L used / 285km travelled (City) ~ 9.09L/100km ~ 25.88mpg (US wet measure)

(remember I have an autotragic)

almost what Dave5635 got for his earlier mileage

what I did differently

- Slightly over-inflated tires 33psi vs 30psi
- Ran some injector cleaner before fillup
- Removed front resonator and snorkeled air intake to behind front headlight

So some slight improvement with the tire pressure.

Will be changing tires soon

[D]iesel

[Edited by diesel204 on May 18, 2006 11:13 PM]
 

·
Registered
Joined
·
95 Posts
In accent you have to use at least 92 octane fuel.

With 87 octane your fuel consumption must be higher and you are damaging the engine (slowly, slowly... but you do).

Even lawnmower needs 92 octane gas.

In my X3 I use 9,5-10 liters per 100km while city driving;
My father's ford focus 2.0 takes 13 liters per 100km city driving;
My fiat argenta 2.0 apetite was 14-15 l (on 95 octane, on 98 - 13liters)
Fiat mirafiori 1.6 11-12l
My friends cars: Audi a6 2.8 - 17-20l
Renault Clio 1.4 - 10-11l
Ford escort 1.3 - 10l
BMW 5 series 2.0 - 15 - 16l
2.5 - 15 - 20l
3.5 - 20 - 25l

All this all normal city driving, slight traffic.
Don't be greedy.
 

·
Registered
Joined
·
386 Posts
That's not right

my car does 477KM for the past tank with 150KM of Hwy, and the rest city.
Less than 50% of hwy driving.

I used to get 550KM a tank if i do like 75% hwy.
One time I got 620KM a tank with all hwy driving.

I run 87 oct most of the time and a tank of 94 oct every month to better clean off the carbon.

I use Chevon (for 87 oct) and Petro Can (for 94 oct).
 

·
Registered
Joined
·
435 Posts
i usually use 87... cuz i'm a broke 17 year old kid lol.... but i love to run 94 , i definitly notice a differance whiel driving and start up, and even more while racing!
 

·
Registered
Joined
·
13 Posts
Discussion Starter #18
Got some new 13" tires (Good Years) and I have noticed the difference.

- Less road noise
- Smoother ride

The mileage has definately improved. Past fillup:

Distance: 312km (all city)
Fuel: 26L (slightly over half tank)

Works out to 8.33L/100km ~ 28.23mpg

So projected Mileage for a full tank would be approx 528km /tank (all city)

My fuel gauge needle is outta whack... the fuel sender needs to be checked....close to Empty and took 26L to bring it to Full. Last I recall 2000 LC had a 45L tank capacity.

Looks like previously cheapo tires were the main culprit.
 

·
Registered
Joined
·
1 Posts
'04 Accent - Finished a round trip from Ottawa to Shelburne Ontario.

Last year I did the same trip and on the way back, the low gas light lit up at around 440km. Because I didn't have a can with me, and it was pretty late at night, I found the closest gas station and filled up..well this time I had a little 5$ can with me and went all the way..the light went off at 440km again, but I was able to get to my friends keep going until around 560km when she started to sputter. This was with pretty strong headwinds on the way there.

On the way back, I had a pretty good tail wind...This time I hit a quarter tank at about 440KM (last time I was below E; this time E was hit at 580km). So I filed up the can again and took a little 45km detour to another friend along the way and another 40Km or so detour to see my mom before finishing the trip home...

I ended up with 650Km on the trip when I finally decided to fill up 2 blocks from home...didn't sputter once and I filled up full with 40 liters of gas, meaning I still had about 5 liters left..

So all in all, I'm pretty happy with my little baby. 8D
 

·
Registered
Joined
·
19 Posts
I have a stock 2001 gs 5speed 76,000kms . and i deliver pizza's for a living. so all city driving i fill up when light goes on. thats at 37.5 liters last 10 fills. i get 510 to 520 kms from this. anyone do the math?

and apperantly 3 sensors are bad.. meybe car is running leaner then it should.. but i can't afford close to 600 dollars just for the sensors plus labor, to replace them atm..
 
1 - 20 of 26 Posts
Top