Hyundai Forum: Hyundai Performance Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
5,883 Posts
Discussion Starter #1
poor gas mileage, accelleration, theres been a few times my CEL came on. i need to change my fuel filter, so its probably that. but last week i was farting around in the engine bay, the car was running and i unplugged my maf. the car idled high for a split second then returned to normal idle. in all my experiences when the maf is unplugged the car barely idles. ive experienced bad maf's before, but the car would shut off until i unplugged it then idle fine, but my car idles fine, and during driving doesnt misfire. could the maf just be on the way out?
 

·
Registered
Joined
·
182 Posts
I am currently having the same problem with my car, I tried replacing the MAF(3 times) I have replaced both O2 sensors, and now my next thing to try is the Idle Air Control Valve. I am having the mechanic check it right now as I have it at a shop for an alignment.
 

·
Registered
Joined
·
56 Posts
Correct me if I am wrong, but I don't think the Idle control valve can cause bad pick up and bad gas milage. You might want to check the purge canister valve. Check the resistance on it, and listen to it as you rev up. It kinda works like a fuel injecter. I would also check the coils.
 

·
Registered
Joined
·
182 Posts
I have checked all the other ****, and the only reason I think that's the problem is because it won't hold an idle with the MAF plugged in.
 

·
Registered
Joined
·
3,276 Posts
Goto webtech and check the voltage on the maf/tps/isa etc.... Check it and be sure before you replace something or go round n round round....
 

·
Registered
Joined
·
182 Posts
I've been checking voltages, replacing stuff, and all it seems to lead to is more round, and round, and round. I am really getting sick of it.
 

·
Registered
Joined
·
737 Posts
regarding the mass air flow sensor, if it was unhooked it should completely stall and throw a cel on the 1.5

o2s would throw a code if they were bad

If i'm correct the fuel filter on the 2000+ accents is at the bottom of the whole assembly in the tank under the rear seats and is a bitch to get to, not to mention messy

when replacing iac valves replace the whole throttle body so the calibration stays in spec
junkyards are plentiful with these things for cheap

If your plugs were going bad you'd feel it, likewise for the wires, the coil packs rarely ever go bad from what i've seen and heard

if you can get your hands on a scanner take the code and go to webtech to see what some solutions to the problem would be

All problems involving gas mileage revolve around fuel/air/spark just find the simplest solutions and replace/clean/fix them till something affects it.

In my line of work if a customer came in complaining about gas mileage i'd suggest a tuneup, fuel filter, air filter, pcv valve, a good carbon cleaning/throttle body cleaning, fuel injector cleaner and go from there, that is if the car was running decent to begin with but if something major is wrong you will know it with a good old check engine light.

good luck guys

oh forgot to add, check for vacuum leaks they usually throw a lean code but sometimes if they are small they won't

[Edited by andy on Oct 13, 2005 6:41 PM]
 

·
Registered
Joined
·
182 Posts
Originally posted by andy
[body]
regarding the mass air flow sensor, if it was unhooked it should completely stall and throw a cel on the 1.5

o2s would throw a code if they were bad

If i'm correct the fuel filter on the 2000+ accents is at the bottom of the whole assembly in the tank under the rear seats and is a bitch to get to, not to mention messy

when replacing iac valves replace the whole throttle body so the calibration stays in spec
junkyards are plentiful with these things for cheap

If your plugs were going bad you'd feel it, likewise for the wires, the coil packs rarely ever go bad from what i've seen and heard

if you can get your hands on a scanner take the code and go to webtech to see what some solutions to the problem would be

All problems involving gas mileage revolve around fuel/air/spark just find the simplest solutions and replace/clean/fix them till something affects it.

In my line of work if a customer came in complaining about gas mileage i'd suggest a tuneup, fuel filter, air filter, pcv valve, a good carbon cleaning/throttle body cleaning, fuel injector cleaner and go from there, that is if the car was running decent to begin with but if something major is wrong you will know it with a good old check engine light.

good luck guys

oh forgot to add, check for vacuum leaks they usually throw a lean code but sometimes if they are small they won't

[Edited by andy on Oct 13, 2005 6:41 PM]
[/body]
My car runs perfectly with the MAF unhooked, but it does throw the CEL. I have put 3 new MAF's on and reset the computer, and after about 1 1/2 days it throws the CEL. It absolutely runs like **** with the MAF hooked up, it won't hold idle, won't rev out, and gets **** for mileage. I really need some help. Some one told me the Idle Speed Actuator or the Throttle Position Sensors will throw the MAF code if they go out.
 

·
Registered
Joined
·
182 Posts
Yeah the Mechanic looked at my car for almost 3 hrs trying to figure out what is wrong with it, to no avail. He wouldn't try throwing a new ISA or TPS on it just to see, he said they couldn't throw the MAF code. He did however check all the vacuum lines, the purge valve, and tried throwing 2 brand new MAF's on it. The funny thing is it wouldn't even run with either one of them, couldn't even get it started without going full throttle, and even at that it was stuck under idle. But guess what, we unhooked it again turned the key and away she went, back to normal (well, normal for her at least).
 

·
Registered
Joined
·
48 Posts
ummm ohh mine has 62000 kms and its falling apart,new tranny at 50000 kms now calipers and mastercylinder cant for get about 220 kms to the last tank of gas,do i dare say lemon.....
 

·
Registered
Joined
·
182 Posts
You guys seriously think the ECU is toast?
That would really suck cock.

In case it helps my car throws a P1128.

[Edited by Accented_illusions on Oct 24, 2005 7:47 AM]
 

·
Registered
Joined
·
19 Posts
Mine does the same thing...works(runs) great w/o the MAF hooked up.Plug it in and it'll run,but performance sucks.If I run wot and bang all the gears it runs...ok...still bogs and sputters.Unhook the MAF and it's like you flipped a switch.Plenty of power,no bogging,no sputtering.I put the MAF back into the stock air box,and hooked everything back up,the cel went out(it is not on in the homebuilt shortrameither)and the car ran just fine.We can't be the only two out here w/LC's who are having this problem(?)Really.what is the worst that can happen w/o the maf hooked up?Worst case I'll either build a longer intake and get the MAF further away from the filter to see if that helps...or Ill give up and replace the factory setup.
 

·
Registered
Joined
·
182 Posts
I tried the factory air box on mine and it still did the same. I have a cai, with the MAF about mid pipe.
 
1 - 17 of 17 Posts
Top