Hyundai Forum: Hyundai Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
sometimes @ idle...when the clutch isnt being depressed...i get this light squeaking noise that resonates through the linkage on the outside of the bell housing...

push the clutch in..and it stops....and doesnt usually start again for some time...

the dealer wants me to replace the entire clutch assembly....at my cost..the so called "warranty" wont cover anything....My LC only has 40k miles on it..:dead:
 

·
Registered
Joined
·
381 Posts
Check where the clutch slave cylinder engages the release fork. That is where mine makes that sound. the tip of the pushrod on the slave cylinder goes dry, and a small amount of anti-seize compound will cure it for a while. Just don't spray any lube down there as it could run down the release fork and work its way onto the the clutch.

A simple test at idle when it is making that sound is to put light pressure on the spot with your finger and see if it goes away.

- JP.8D
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
yeah thats what ive been doing for about 2 years..lol..and yeah..it does stop squeaking if you apply pressure to it....always did..

ive been told by multiple people that it needs a new throwout bearing
 

·
Registered
Joined
·
978 Posts
could be a bearing in the tranny, that's what was wrong with mine. When you pushed the clutch in it would go away.

They covered it all under warranty with rental car for 2 weeks.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
they refused to cover it under warranty...it is the release bearing for the clutch (throwout bearing)

they say because it is a wear related part, they wont fix it:dead:
 
1 - 6 of 6 Posts
Top