Hyundai Forum: Hyundai Performance Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
i went to get my car tuned today (2001 tibby with 440 CC injectors with the SAFC NEO with 57 trim) and when ever my car would get close to boosting it would act like the injectors would shut off and the guy tuning it would be in full throttle and the RPM would be like if you took your foot of the gas pedal which in fact you didn't. so please someone give me some insight about what to do.... the guy tuning it said to hook up a fuel pressure regulator (which i already own but not installed) and get a smaller wastegate spring ( right now i have a 9 pd spring) because it is easier to trouble shoot with a smaller spring... but other then that im open to any ideas...thanks:confused::confused::confused:
 

·
Registered
Joined
·
1,787 Posts
Sounds like a MAP sensor problem...try this...Not sure it will work but worst case is the problem still persists. Dissconect your O2 sensor on your header...I did it to my car and the bogging and hessitation went away...440cc injectors should be plenty of fuel but because the O2 sensor is reading it as too much the ECU goes haywire...(just a guess).
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #3 ·
Sounds like a MAP sensor problem...try this...Not sure it will work but worst case is the problem still persists. Dissconect your O2 sensor on your header...I did it to my car and the bogging and hessitation went away...440cc injectors should be plenty of fuel but because the O2 sensor is reading it as too much the ECU goes haywire...(just a guess).

im sorry i forgot to add that i disconnected my o2 sensors because someone suggusted that before becuase they said they did that on there car and it worked and they used the SAFC as the fuel map... and the guy tuning it also said that i should have more then enough fuel... but the car still reads lean...
 

·
Registered
Joined
·
1,787 Posts
how much boost you trying to push here? If less than 10 then you should be fine...i know my map sensor is dead. tried to get an OBDII sensor reading and it was stuck at 37...whatever that means but not sure though...something with your ecu is giving you a problem...
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #5 ·
thats what i assumed too that it was my ECU... another thing that i found out was that some ppl had there ECU reflashed to support the larger injectors which makes since but the thing is idk where to get that done at...any ideas???
 

·
Registered
Joined
·
3,276 Posts
Provided the afc is hooked up right Check the spark plugs, you didnt mention nothing about them. You shouldnt be bogging, try closing the gap and make sure the plugs are at least one stage colder!
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #7 ·
im a freaking idiot!!!!!!!!!!

Provided the afc is hooked up right Check the spark plugs, you didnt mention nothing about them. You shouldnt be bogging, try closing the gap and make sure the plugs are at least one stage colder!
i dont know what i was thinking... closeing the gap is the first thing i shouldve done when going turbo... my friend read what you said and he told me WTF were you thinking not closeing the gap... he's running a .028 right now in his WRX so i was just wondering what your running so i have a rough idea to start from... thanks youve been a real help!!!!
 

·
Registered
Joined
·
3,276 Posts
Running under 15psi i was using a .28 gap, over 15psi I cant remember but it was a very little gap lol
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #9 ·
Whoa!!!!!!

all i have to say is wholly ****!!! putting my gap at .028 made my car drive like the first day i bought it and i told my same friend with the WRX that and then he suggested taking off the air filter and it will run even better...thats what he had to do to his car and it runs like a champ now... so thanks for the help and if u want ill keep you updated on my car...later bro
 

·
Registered
Joined
·
3,276 Posts
Glad to hear its running good, but whatever you DO NOT remove the air filter! Last time my friend did that he sucked up some dirt or something and it cost him $1200 (ruined his gt28 turbo). Your friend probably just needed a new better flowing filter.
 
1 - 10 of 10 Posts
Top