Hyundai Forum: Hyundai Performance Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
860 Posts
Discussion Starter · #1 ·
Ok so last month I put my car on the dyno and found out i had some fuel problems! so we replaced the fuel pump, fuel pump regulator and the ecu (put in a 1.8, that was alot better than mine which we think is going bad) well it helped ALOT!! but was still bogging down a little bit well because we finally switched out my bad ecu with a good one it finally threw a code...
P1127, which is a fuel code! well we switched out one of the two O2 sensors (the other one on the manifold we couldnt get to cuz the radiator is in the way) it does run alot smoother it still bogs down but more consistantly and smoother, not rough and inconsistant!!

other than the other O2 sensor what else can i do to fix this problem!! were definately making progress though so im happy bout that plus i found out im way smarter than the guys at Shucks!! LOL!!:D
 

·
Registered
Joined
·
13,145 Posts
I forget, have you replaced the MAF?

Besides that we need to get it on the scanner and see what we can find out.
 

·
Registered
Joined
·
860 Posts
Discussion Starter · #5 ·

·
Registered
Joined
·
860 Posts
Discussion Starter · #6 ·
But I bet they spell it 'Schucks' ;)







:D



BTW: I left you a note on your SATCO invoice when I was there today. :cool:
LOL!!! sorry i was in a hurry!! you were here?? the one in South Seattle on Andover st?
 

·
Registered
Joined
·
860 Posts
Discussion Starter · #7 ·
I forget, have you replaced the MAF?

Besides that we need to get it on the scanner and see what we can find out.
we tried swapping it out for a newer one and it worked for awhile but than went back to its old self but that was also before we swapped out the ecu so my ecu was making a lot of the problems worse than it should've been
 

·
Registered
Joined
·
2,809 Posts
BTW: I left you a note on your SATCO invoice when I was there today. :cool:
you were here?? the one in South Seattle on Andover st?
No. I was at SATCO scribbling on your invoice when their employee walked up.:eek:

I saw your invoice because your order was sitting on the ground next to mine.:cool:
 

·
Registered
Joined
·
860 Posts
Discussion Starter · #9 ·
No. I was at SATCO scribbling on your invoice when their employee walked up.:eek:

I saw your invoice because your order was sitting on the ground next to mine.:cool:
Oooohhhhh!!! ok got ya!! LOL!
 

·
Registered
Joined
·
860 Posts
Discussion Starter · #10 ·
Im still needing some help guys!!! We have replaced the fuel filter, fuel pressure regulator, both O2 sensors and the fuel pump! Its still hesitant...its gotten alot better but it still doesnt have the hp it should and almost no torque now! Any ideas!?!? Im thinking about just giving it to the shop we have had working on it since they know the history! Im just scared about how much it will cost! Im thinking that it cant be too expensive since we have replaced just about everything it could be and we are just thinking that it might just be something simple that we just havent thought of! If this is the case can anyone give me some ideas what it could be and how much it would cost!?!?

We also think that it might be my muffler or exhaust might be clogged from having an old CAT...which would be fixed once I put my new header on but havent yet cuz well with two jobs its kinda difficult to give Wilbur my car to do that!!
 
1 - 10 of 10 Posts
Top