Hyundai Forum: Hyundai Performance Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Hi again..
Lately i hear a noise from the front left wheel..
I jacked the car up and tried to rotate the wheel.I heard a noise like a spring or sth does this noise.Do you think its the bushes going south or sth.Can the sway bar be damaged or sth?Waiting for your feedback


<hr noshade width=60% size=1 align=left>
 

·
Banned
Joined
·
5,451 Posts
Do you hear the noise when you turn a corner? or when you hit bumps and pot holes? or normal daily driving? You have the Eibach springs, right? Did you get the pro dampers as well, or are you still rollin on stock shocks and struts? Is your sway bar stock, or do you have an aftermarket one?

- If you have stock shocks, they might be going, and may need new ones.

- If you have an aftermarket sway bar, check all your bushings and fittings. Make sure they're all lubed up and nothing is pinched or rubbing.

Also, an easy way to determine the problem is to get a friend and have him bounce the car up and down a little while you try and pin point where the squeeks are coming from. Then you can go from there and resolve the issue. <img src=/images/forums/snitz/thumbup.gif width=25 height=18 border=0>


<hr width=60% noshade size=1 align=left><img src="http://www.mustangmods.com/publish/OceanSurfer1977/me.jpg" border=0>
<p><b>We do not stop playing because we grow old; we grow old because we
stop playing.</b>

<b>You're not a true street racer until you've had your car impounded!</b>
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #3 ·
Hi Jos,this only happens when the wheel is rolling.I dont have aftermarket swaybar.I currently use eibach springs with stock struts and schocks.This noise is caused only by the rotation of the wheels.I have also tried to bounce up and down the car and i cant hear that noise.Do you think its probably the bearings that are inside the rotor(disc)??I will sure get the prodampers in the near future..


<hr width=60% noshade size=1 align=left>
 

·
Registered
Joined
·
694 Posts
it might be your bearing.... mine has gone out like two times and one other guy's accet's bearing has gone out like 5 times


<hr width=60% noshade size=1 align=left>
 
1 - 5 of 5 Posts
Top