Hyundai Forum: Hyundai Performance Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
468 Posts
Discussion Starter #1
Hey all, I was cruisin around last night in my turboed 99 hyundai excel twincam and i had to do a few u turns and on my last one i heard a scraping sound from the wheel wells. i thought it was nothing but as i drove off the sound stayed so i pulled up 100m down the road and looked in both wheel wells and the guards were all messed up! i had to rip chunks out just so i could drive off without the sound and now there are big gaps in there and im worried if water might get in th enginebay when it rains! what can i do!!!

my car was lowered using king superlow springs and boge shock absorbers but yeah i mustve bottomed out too hard somewhere n made the wheel rip the guards or somethin... should i be worried? what can i do?
 

·
Registered
Joined
·
5,294 Posts
I hit a dog within a year of getting my car. Everything was repaired except that the body shop ordered the wrong side for the wheel well plastic, and I've driven without the plastic for a few years now with no issues.

If you have a CAI, I would exercise caution, but I doubt you'll get much in the engine bay.
 

·
Registered
Joined
·
3,276 Posts
Mine has been missing on the passenger side since I hit something in the road over a yr ago, no big deal.
 

·
Registered
Joined
·
48 Posts
i have none all the way around, just a lil bit covering my cai on the drivers side, alternator squaels whenever i go through a puddle lol.
 

·
Registered
Joined
·
468 Posts
Discussion Starter #6
I guess its only really a problem on my driver-side guard since my pod filter is mounted in there right behind my corner indicator... Will dirt n crap reach it up there if my guard is rooted?
 

·
Registered
Joined
·
1,040 Posts
yea, my wheel well guards are well intact, for a 2001 its been stock since i have gotten it, but im going to lower it right after christmas, hopefully i don't run into these problems, but if so, no biggie
 
1 - 7 of 7 Posts
Top