Hyundai Forum: Hyundai Performance Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
978 Posts
Discussion Starter #1
The past couple of days, the temp has been rising where it never has before.

At 70 mph the temp gauge is right in the center, where it should be, when I bump it up to 80-100 it starts rising fast. It has never gotten into the red zone, but what would cause that. When I back it back down to 70 it drops again. When I drop it down to 75 it drops a little, but not back to where it was.

Also, this morning, 4th gear same thing, at 60 in 4th it started rising.

When crusing at 70 mph you would not be able to tell anything is wrong. I figure it cannot be the fans, since they do nothing at 70+, the coolant level is full, as the the oil. Could a thermostat do this, at idle the temp is fine as well. I am stumped on this one. (going to be putting in a new thermostat anyways, just to be sure.

any ideas?
 

·
Registered
Joined
·
176 Posts
check your thermostat, it might not be opening fully at those high speeds and lettin the coolant in to flow all the way. im pretty sure that should be it


[Edited by Excel2NR on Jan 24, 2006 9:40 AM]
 

·
Registered
Joined
·
176 Posts
[Edited by Excel2NR on Jan 24, 2006 9:39 AM]
 

·
Registered
Joined
·
7,118 Posts
Thermo has nothing to do with speed but if it was only partially opening and could causing that issue. They are cheap and if you dont want to shell out the money for a new one you can test it on the stove. Is your radiator clean on the outside and then what about internally (miles?). It might not be flowing well enough at sustained higher rpms to keep the motor cool. When was the last time you changed the coolant?
 

·
Registered
Joined
·
978 Posts
Discussion Starter #5
Coolant is changed every fall, proper mix of 50/50, and it's never come out dirty.

The radiator itself is clean on both the front and back, with almost 0 damaged fins. So it's dissapating the heat properly.

That's why I am stumped. I am going to put a new thermostat in tonight (I would anyways, I would not take the neck apart and put a 5 year old part back in lol. That's like reusing a timing belt.

Thanks for the advice, chances are it has to be the thermostat, will see how it acts tomorrow. I drive 50 miles a day (25 miles round trip) to work and home, peace of mind would be good.

Any other ideas guys?
 

·
Registered
Joined
·
978 Posts
Discussion Starter #7
I just got the premium 3.99 STAT thermo, should I take pics for a how to? I will anyways. It's a simple thing so should not be a problem for anyone.

I went with the 180 because of the turbo project in the near future, instead of te 195. It's only 15 degrees so should not be a problem in any way

Dan
 
1 - 7 of 7 Posts
Top