Hyundai Forum: Hyundai Performance Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
1,489 Posts
Discussion Starter · #1 ·
Ok, so I installed my wideband aem uego and here we go: Setup:
2.0 beta1 engine, with 1.6 LC ecu, 1.8L camshaft, unorthodox underdrive crank pulley, beta2 coilpacks, beta2 intake manifold(stock) , beta2 injectors(190cc), hks mushroom filter, obx headers, 2.25 exhaust, resonator and a stock 1.8 nissan almera muffler. Here we go.. I start the car and I see 14.7. I say ok and here we go. WOT 1st gear shows 13.2:1, 2nd, 13.2:1, 3rd the same and 4th the same! I say what the hell is this? The car running 1.6 ecu and the other stuff should be **** and needs tuning! My safc is set at 0% values everywhere! Now what the **** is this? This is not only good. This is incredible! Not even with a piggyback? Strange **** here.. I won't mess with it anymore that's for sure!!!!! P.S. at half throttle I am reading 14-14.7 which is also cool! hehehe... I like this!
I managed to tune the car diy without a piggyback! ;)
 

·
Registered
Joined
·
1,787 Posts
Sounds good! How much was the Wide band?
Ok, so I installed my wideband aem uego and here we go: Setup:
2.0 beta1 engine, with 1.6 LC ecu, 1.8L camshaft, unorthodox underdrive crank pulley, beta2 coilpacks, beta2 intake manifold(stock) , beta2 injectors(190cc), higher compression (mild the head by 3/10ths) hks mushroom filter, obx headers, 2.25 exhaust, resonator and a stock 1.8 nissan almera muffler. Here we go.. I start the car and I see 14.7. I say ok and here we go. WOT 1st gear shows 13.2:1, 2nd, 13.2:1, 3rd the same and 4th the same! I say what the hell is this? The car running 1.6 ecu and the other stuff should be **** and needs tuning! My safc is set at 0% values everywhere! Now what the **** is this? This is not only good. This is incredible! Not even with a piggyback? Strange **** here.. I won't mess with it anymore that's for sure!!!!! P.S. at half throttle I am reading 14-14.7 which is also cool! hehehe... I like this!
 

·
Registered
Joined
·
6,344 Posts
I'd still try to get the car on the dyno as you might find the car makes more power with a slightly richer a/f ratio. Make sure you run mid-grade or better pump gas just in case as thats pretty lean.
 

·
Registered
Joined
·
1,787 Posts
Not sure if all Hyundais are this way but my Alpha runs better when its lean, not sure. See when I was getting my car dynoed with the turbo I was getting 138-142 but I was OFF THE CHARTS LEAN. Richen it up and the power went down to 119-124...so who knows.

I'd still try to get the car on the dyno as you might find the car makes more power with a slightly richer a/f ratio. Make sure you run mid-grade or better pump gas just in case as thats pretty lean.
 

·
Registered
Joined
·
686 Posts
you get more power when ur lean, but in turn it destroys the engine a lot faster
 

·
Registered
Joined
·
124 Posts
I keep hearing here that lean = power but everything I read elsewhere says that 13.0-1 at max torque rpm and 12.5-1 at max horsepower rpm it considered ideal for making the most power overall. Here is a quote from wiki:
In Naturally Aspirated engines powered by octane, maximum power is frequently reached at AFRs ranging from 12.5 - 13.3:1 or λ of 0.85 - 0.901.
 

·
Registered
Joined
·
1,489 Posts
Discussion Starter · #7 ·
And those number are exactly what my aem says. It's really strange that with the 1.6 ecu the car runs like this.Maybe the narrowband sensors do some job and the kefico autotunes itself... i don't know!
 

·
Registered
Joined
·
9,188 Posts
Nice. How much was the wideband?
 

·
Registered
Joined
·
1,489 Posts
Discussion Starter · #10 ·
The wideband is the AEM uego which costs 230 shipped to US ;)
 

·
Registered
Joined
·
845 Posts
my wideband also shows a proper afr for my 1.6ecm beta swap when it is n/a. The lack of power in the 1.6 ecm is due to the ignition timing map. Also the head the the beta sucks n/a.
 

·
Registered
Joined
·
1,489 Posts
Discussion Starter · #12 ·
The lack of power in the 1.6 ecm is due to the ignition timing map. .
That is exactly the point here.. The thing is... what can we do about it relatively cheap???
 

·
Registered
Joined
·
1,489 Posts
Discussion Starter · #14 ·
How about AEM FIC?
 

·
Registered
Joined
·
502 Posts
I just bought that same wideband kit because I broke my stock o2 sensor.
I'm curious to know how many ponies u have at your wheels so though your car on the dyno.
 

·
Registered
Joined
·
502 Posts
is there a way the ecm can get an o2 reading out of the wideband o2 sensor?
because i dont want to drill another hole i just want to use the wideband o2
 

·
Registered
Joined
·
6,117 Posts
is there a way the ecm can get an o2 reading out of the wideband o2 sensor?
because i dont want to drill another hole i just want to use the wideband o2
That depends on your wideband. Check the literature that came with it. If it has a one volt output, that's the wire you need to splice into your factory O2 sensor wire.
 
1 - 18 of 18 Posts
Top