Hyundai Forum: Hyundai Performance Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
864 Posts
Discussion Starter · #1 ·
when you go to take off it bucks or hesitates for like a second an then full power and then dies and then full power for the rest of the gear.....i know that it needs a fuel filter and a air filter....which would be the obvious anwsers but do the 1.5's have the same bullshit sensor inside the intake manifold that the old excels used to have??


<hr noshade width=60% size=1 align=left>
 

·
Registered
Joined
·
6,806 Posts
What year is the Accent, ONLY1DB? Manual or automatic? If the fuel filter is long overdue to be replaced, then that's the first thing I'd do.
Is the check engine light on? And how long has the car been acting like the way you describe?
Accents have a couple of sensors in the intake system, one to measure the volume of air being sucked into the engine, and another to monitor the air temperature. If either of these if faulty, the check engine should be on.


<hr width=60% noshade size=1 align=left>
 

·
Registered
Joined
·
1,170 Posts
Check your fuel filter and Oxygen sensors. I'm guessing one of those would be the problem. Had a similar problem on my old Jeep Cherokee. Finally replaced the oxygen sensors and it stopped. <img src=/images/forums/snitz/smile.gif width=15 height=15 border=0>


<hr width=60% noshade size=1 align=left>2000 Hyundai Elantra GLS
-PIAA 1100x superwhite foglights
-PIAA Plasma headlights
-Sharkracing clear corners w/ amber bulbs
-Deflector
-10" pioneer subwoofer w/ 600 watt Kenwood amp
-Blue dome light
 

·
Registered
Joined
·
21,319 Posts
Both a bad fuel filter and a bad air filter can cause the car to buck so I would replace both of those then reset your ECU. If it is an X3 accent have fun changing the fuel filter. It looks easy cause of where it is located but it is a b!tch.<img src=/images/forums/snitz/guns.gif width=33 height=16 border=0>


<hr width=60% noshade size=1 align=left><font color="red" size="4">Hyu</font><font color="orange" size="4">ndai</font><font color="yellow" size="4">Tun</font><font color="green" size="4">er =</font><font color="blue" size="4"> t3h</font><font color="purple" size="4"> ghey</font>
 

·
Registered
Joined
·
6,806 Posts
Yeah, AUTOBOT's right... I tried to replace my fuel filter, but couldn't get the bolts to budge, but I damn near bent the bracket all to hell. I just went to my garage and had them do it. That way if anything got broken, I wouldn't really be responsible.
However, that is where I would start.


<hr width=60% noshade size=1 align=left>
 

·
Premium Member
Joined
·
5,554 Posts
hmmm... maybe I should replace the filters also... probably need a new fuel filter and air filter anyhow.

Kirk... reset the ECU? would that normally need to be done with replacing parts, or would that just let the computer adjust properly?


<hr width=60% noshade size=1 align=left><img src="http://www.fxtreme.org/members/Red_GT/redagt4.gif" border=0>
[=1997 Red Accent GT=]

Edited by - red_agt on 02/18/2002 6:28:23 PM
 
1 - 6 of 6 Posts
Top