Hyundai Forum: Hyundai Performance Forum banner

1 - 20 of 80 Posts

·
Premium Member
Joined
·
2,605 Posts
Discussion Starter #1










Okay, i'm documenting this swap (because no one else has for the x3) before i deliver the sold car. I'll post pics as I go about doing it. I do have a job and will not be devoting all my time during the day to work on this car (its currently taking up one of my lifts at work:dead: )

Parts for the swap include (so far)

2000 Elantra engine with flywheel and passenger motor mount to match.
1998 Accent tranny.
2003 Accent clutch.

So this is on the day before i start anything (completely stock)
 

·
Premium Member
Joined
·
2,605 Posts
Discussion Starter #2
Here ya go:

1. Remove factory intake and battery along with tray.


2. Drain all fluids. Disconnect all wiring, heater hoses, a/c hoses, axles, exhaust, clutch cables, and whatever else is under there. (I ran into a black widows nest in the brake caliper, that ugly spider got nasty mad. good thing brake cleaner kills) And please do us all a favor and evacuate the a/c lines with a machine before taking them off.


3. Now remove radiator and fans as one piece.



4. Now to take the engine out. I opted to raise it out with a hoist instead of dropping it from below on a lift. I have access to things like that (dealership has plenty of good toys to use). I removed the bolts for the mounts on the bottom of the engine and tranny while it was in the air (while taking axles out). To get the tranny and motor out all at once, you will need to remove the driver side tranny mount from the body (4- 12mm bolts in the fender well) and the passenger side motor mount from the engine. Now jack the motor up and out. watch for the hoist arm hitting the hood if you left the hood on the car. Now you have an empty engine bay.


5. Now you have a spare motor to sit aside.


6. Now get the beta motor.


7. Swap the altenator from the alpha onto the beta (direct fit) and place the belt onto it.


8. now put the alpha tranny onto the beta motor using the beta flywheel and 1.6 alpha clutch and then the 1.5 alpha tranny and it all lines up just fine.. no need for a scoupe turbo clutch at all.

9. drop the motor back in place the same way you took it out. make sure you have the a/c condensor and hard lines out the car or it will become a PITA. line up all the tranny mounts first and bolt them back up.

10. now that all tranny mounts are in, the motor mount is the biggy. place the beta motor mount onto the engine. now mark where the hole would be in the mount position on the body. remove beta mount and drill hole. replace beta mount and bolt in using locking washers...

11. reconnect all the wiring and fill and top off all fluids. (only a few sets of wires needed to be extended and those will be obvious at the time, just use solder and the same gauge wire). Hopefully you use an aftermarket intake as the stock from either engine will not fit now. I just left it at an open maf.

12. fire it up and voilla. CEL will stay on period. Unless u decide to change ecu's and wire harness'. I got lazy and decided to keep the CEL.

HOPEFULLY THIS CAN BE A STICKY NOW

ANOTHER SUGGESTION FOR THE PASSENGER MOTOR MOUNT

well i tried something different and it goes like this (works perfectly)
Use the 1.5 original mount. grind off the bracket for the harmonic balancer and the top three tube ends. on the beta motor itself, cut off the stud closest to the engine itself. remove the spacer bracket and dispose of it. now grind the side where the bolt goes thru on the 1.5 mount itself on both sides. slide into place and drill hole in frame bracket to match within the mount. Bolt it up and its done. I'll have pix of the final result up soon of this method.
 

·
Registered
Joined
·
1,054 Posts
thegrim, let me be the first to thank you for this... Nice job so far, can't wait to see the rest of the write up. Btw, that's exactly where I am with my swap right now, lol. ;): Wish I had a digi cam...
 

·
Registered
Joined
·
508 Posts
i thought you were puting the beta 2 in your lc2???
 

·
Registered
Joined
·
3,276 Posts
Originally posted by thegrim
[body]
well unfortunately i'm not. i'm trying to trade my lc2 in for an srt-4. so i'm putting a beta in this x3 and selling (sold) it.
[/body]

More like sold out! HAHA J/K MAN... Good luck with the srt-4 and Im interested in seeing how this swap goes.....
 

·
Registered
Joined
·
1,903 Posts
Originally posted by thegrim
[body]

1998 Accent tranny. (Clutch)
[/body]
Are you planning and using the clutch from the accent??? If so won't work.. needs one out of a scoupe turbo.. and i would recommend getting an aftermarket clutch cuz the stock one sucks.. a lot of slipping...

I was going to do a write up but never ended up getting the time to do it.. i should still have all my pics from my swap somewhere...
 

·
Registered
Joined
·
3,943 Posts
the beta flywheel is about 1/2" bigger than the accent flywheel. i am interested in knowing how well the starter will fit. if you use the tib flywheel you will need a scoupe turbo clutch to mate on it to be used with teh push type clutch slave cylinder. if you use the beta tranny you will need a beta pull type clutch to work with the slave cylinder setup. but unless the later (97+) accents used the larger clutch which the 1995 models did not then youll need a scoupe turbo clutch on a beta flywheel. but if your 1998 clutch was upgraded from the size that i know the 95 accents had, then it will work. ive never worked with a late model x3 inards, only a 95 and LC and a bunch of betas. and my scoupe of course :)
 

·
Premium Member
Joined
·
2,605 Posts
Discussion Starter #10
finally i got the beta motor delivered to me and had time to prep it for the swap.

I still need the 1.6 accent clutch to mate the tranny to the block.

00 elantra 2.0L DOHC> matching flywheel> 1.6 accent clutch> 1.5 accent manual tranny

[Edited by thegrim on Oct 27, 2005 2:52 PM]
 

·
Premium Member
Joined
·
2,605 Posts
Discussion Starter #11
and the swap is done after a full day of hard work. between jobs that my service writer threw at me, i got this thing put back together and running. but there is a CEL that wont go off. there is no way to fix it unless we take the bulb out, lol. i'll finish the write up later. i didnt take pics of the process going back in because i was hustlin. i will include full detail instructions though...
 

·
Registered
Joined
·
1,054 Posts
Wow, just one day... Congrats!
 

·
Registered
Joined
·
582 Posts
PLease do......i need all the help i can get when i swap out for the beta.....
 

·
Registered
Joined
·
1,965 Posts
Dude, get some pics up for sure. Would like to see it and some pics of the mounts to:)
 

·
Registered
Joined
·
1,054 Posts
^^What he said. :) Even just some low res pics of everything in the engine bay would be fantastic. I'm really looking forward to this.

Drerob -- just wanted to let you know I'll be getting on that harness again soon. Weather has been kinda crummy here lately (snowed today again) and I had to devote last weekend to changing the blown struts and springs on my Escort. :ermm:
 

·
Registered
Joined
·
1,965 Posts
^^No biggie, just get it to me when you can^^

Grim, weres the pics?
 

·
Registered
Joined
·
1,965 Posts
^^it is monday^^ :)
 

·
Registered
Joined
·
1,965 Posts
Originally posted by rbuecker
[body]
it's more tuesday than it is monday :D
[/body]
lol, yea i guess so
 
1 - 20 of 80 Posts
Top